Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Apache SuEXEC = Premature end of script headers as of 7:30 tonight

Discussion in 'EasyApache' started by boatdesign, Jul 29, 2009.

  1. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    166
    I am not seeing an update that took place at 7:30, but for some reason at 7:30 tonight all perl scripts on the server began erroring with /usr/local/apache/logs/error_log containing
    Premature end of script headers: (and then the path to the script, etc.)

    Also cpanel's /webmail and /cpanel urls began returning Internal Server Error at exactly the same time.

    They work if I now turn Apache Suexec off, but I want it on as it has been for the last years (and need it to be for other perl scripts on the server.)

    This is WHM latest stable. RHEL 5 32-bit OS.
    perl -version
    This is perl, v5.8.8 built for i686-linux
    Apache 1.3.x

    Any ideas or help you can offer would be greatly appreciated.
     
    #1 boatdesign, Jul 29, 2009
    Last edited: Jul 29, 2009
  2. boatdesign

    boatdesign Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    166
    Lesson:
    Always check the simple things first.

    Problem was /usr/local/apache/suexec_log reached 2.0 GB in size. Ahhh!

    I thought these rotated, but either the rotation stopped at some point or suexec_log was never being rotated and I finally hit that limit.

    I've run into an individual domain log reaching the 2 GB limit and killing apache before, but I didn't think of the obvious in this case.

    Well, now I have a newly built apache, cpanel forced update, and clean per reinstall, and a good lesson to check the obvious first, always! I was convinced there must have been some software update at 7:30 or an os update that was killing suexec. So always check the simple things first, and remember old lessons you've learned before.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,216
    Likes Received:
    10
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Don't forget, you may want to enable log rotation for suexec_log by going to WHM -> Service Configuration -> Apache Configuration -> Log Rotaton
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice