Millar

Active Member
Dec 23, 2006
29
0
151
When using Apache update to update to PHP 5.2.0, the installation installs as normal, but when I attempt to open any page on my server, my browser simply prompts me to download the file. It says it is an application/x-httpd-php . Am I doing something wrong or is there something I need to do?

Thanks in advanced,
Sam Millar.
 

Millar

Active Member
Dec 23, 2006
29
0
151
When you do choose to save the files via the prompt, you can download the full PHP source code un-parsed so it looks like it is a problem with PHP just not working.

Any ideas?
 

katmai

Well-Known Member
Mar 13, 2006
564
3
168
Brno, Czech Republic
check httpd.conf line that says loadmodule... php ...

anyway if the line is set to php4 just simply put in php5 and restart the apache.
 

Millar

Active Member
Dec 23, 2006
29
0
151
Doesn't work, just makes apache fail because that file doesn't exist in the libexec directory,only the php4 version does.
 

jinsonxu

Registered
Jan 1, 2007
1
0
151
Have the same problem, suspect your php build failed.

I've tried a few times and have yet to get php 5.2 (from cpanel edge) to compile with apache 2.2.3. The make seems to fail during the imap check. Am trying to find out where the detailed make log is so i might be able to fix the imap problem manually.

On the otherhand, i'm already so frustrated by this i might simply revert to cpanel current and go with php 5.1.6. grr...
 

Millar

Active Member
Dec 23, 2006
29
0
151
When using the update program, it doesn't say that it failed, it says that it was successful although PHP just doesn't work.
 

Millar

Active Member
Dec 23, 2006
29
0
151
I still have this problem, any other ideas on a fix?

Update says:
Building Apache Config.....Done
Downloading and compiling apache+modules....

Fetching http://layer1.cpanel.net/buildapache.sea (0)[email protected]%...3%...4%...6%...7%...9%...10%...12%...13%...15%...16%...18%...19%...21%...22%...24%...25%...27%...28%...30%...31%...33%...34%...36%...37%...39%...40%...42%...43%...45%...46%...48%...49%...51%...52%...54%...55%...57%...58%...60%...61%...63%...64%...66%...67%...69%...70%...72%...73%...75%...76%...78%...79%...81%...82%...84%...85%...87%...88%...90%...91%...93%...94%...96%...97%...99%...100%......Done
Verifying archive integrity... All good.
Uncompressing buildapache..........................................................................................................................................................................................................................................
Checking Update System........
Verifying compiler and libs....Verifying installation....Using RPM Backend: RPM version 4.4.2
Fetching rpm updates list...Error 404 while fetching url http://updates.cpanel.net//pub/rpminstall/fedora-5/updates.686.db.gz.md5
This could indicate you have not properly configured an update source:
To select an update source create a file in /var/cpanel called use[sourcename]
For example:
/var/cpanel/useurpmi - URPMI (Mandrake,Mandriva)
/var/cpanel/useyum - Yum (CentOS,Fedora)
/var/cpanel/useup2date - U2pdate (RHEL)
/var/cpanel/useswup - SWUP (Trustix)
/var/cpanel/userug - Rug (SuSE)
/var/cpanel/useapt - Apt-Get (Debian)
/var/cpanel/useemerge - Portage (Gentoo)
cached /root/.cpupdates/2-9-2007.updates is up to date...Error 404 while fetching url http://updates.cpanel.net//pub/rpminstall/fedora-5/updates.686.db.gz
This could indicate you have not properly configured an update source:
To select an update source create a file in /var/cpanel called use[sourcename]
For example:
/var/cpanel/useurpmi - URPMI (Mandrake,Mandriva)
/var/cpanel/useyum - Yum (CentOS,Fedora)
/var/cpanel/useup2date - U2pdate (RHEL)
/var/cpanel/useswup - SWUP (Trustix)
/var/cpanel/userug - Rug (SuSE)
/var/cpanel/useapt - Apt-Get (Debian)
/var/cpanel/useemerge - Portage (Gentoo)
Done
Fetching rpm provides list...Error 404 while fetching url http://updates.cpanel.net//pub/rpminstall/fedora-5/provides.686.db.bz2.md5
This could indicate you have not properly configured an update source:
To select an update source create a file in /var/cpanel called use[sourcename]
For example:
/var/cpanel/useurpmi - URPMI (Mandrake,Mandriva)
/var/cpanel/useyum - Yum (CentOS,Fedora)
/var/cpanel/useup2date - U2pdate (RHEL)
/var/cpanel/useswup - SWUP (Trustix)
/var/cpanel/userug - Rug (SuSE)
/var/cpanel/useapt - Apt-Get (Debian)
/var/cpanel/useemerge - Portage (Gentoo)
Done

/scripts/ensurerpm [@buildapache]...(--quiet --safe libxpm4 ImageMagick libxpm4-devel libxpm4-dev ncurses ncurses-devel ncurses-dev libncurses5 libncurses5-devel libncurses5-dev gettext gdbm gdbm-devel libgdbm2-devel libgdbm2-dev db4 db4-devel db4-dev db1 db1-devel db1-dev db1-tools patch kernel-headers linux-headers glibc-kernheaders pam-devel pam-dev krb5-devel krb5-dev openssl openssl-devel ssl-dev libssl-dev openssl-dev libopenssl0 libopenssl0-devel libopenssl0-dev flex lex bison glibc-devel glibc-dev gcc gcc-c++ libgcc cpp libstdc++ libstdc++-devel libstdc++-dev jpeg libjpeg libjpeg-devel libjpeg-dev libjpeg62 libjpeg62-devel libjpeg62-dev png libpng libpng-devel libpng-dev libpng10 libpng10-devel libpng3 libpng3-devel libpng3-dev libtiff libtiff-devel libtiff-dev libtiff3 libtiff3-devel libtiff3-dev XFree86-libs XFree86-devel XFree86-dev libopenssl0.9.7-devel libopenssl0.9.7-static-devel libltdl xorg-x11-devel pspell pspell-devel zlib zlib-devel zlib1-devel libz-devel tdl aspell aspell-devel xorg-x11-devel libc-client-devel libtool automake libungif-devel libtool-libltdl-devel libtool-ltdl-devel libltdl-devel libltdl3-devel).... Done

Done
Done
********************************
This is buildapache version 1.5.402 (for cpanel <= 10.9.3) (ap=1.3.37)
********************************
buildapache configured from Web Host Manager
Apache configured from Web Host Manager!
/etc/rc.d/init.d/httpd start: httpd started
Fetching http://httpupdate.cpanel.net/buildapache/1/libxml2-2.6.22.tar.gz (0)[email protected]%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done

./configure [@libxml2-2.6.22]...(--libdir=/usr/lib64 --prefix=/usr).... . . . . . . . . . . . . . . . . . . . . . . . Done

make [@libxml2-2.6.22]...(-j 2).... . . . . . . . . . . . . . . . . . . Done

make[2]: *** [parser.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

make [@libxml2-2.6.22]...(install).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

make[1]: *** [testapi.o] Error 1
make: *** [install-recursive] Error 1
Fetching http://httpupdate.cpanel.net/buildapache/1/php-5.1.6.tar.gz (0)[email protected]%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
Untarring php....Done
Running configure:
LDFLAGS="-L/usr/X11R6/lib64" /home/cpapachebuild/buildapache/callbacklog --prog configure --dir /home/cpapachebuild/buildapache/build-log -- --enable-pic --with-apxs=/usr/local/apache/bin/apxs --with-libdir=lib64 --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib

./configure [@php-5.1.6]...(--enable-pic --with-apxs=/usr/local/apache/bin/apxs --with-libdir=lib64 --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

make [@php-5.1.6]...(-j 2 clean).... Done

make [@php-5.1.6]...(-j 2).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

make: *** [ext/date/lib/parse_tz.lo] Error 1
make: *** Waiting for unfinished jobs....

cc1: out of memory allocating 1109952 bytes after a total of 27516928 bytes
make: *** [ext/date/lib/parse_date.lo] Error 1

make [@php-5.1.6]...(install).... . . . . . . . . . . . . . Done

make: *** [ext/date/lib/parse_date.lo] Error 1
/etc/rc.d/init.d/httpd start: httpd started

./configure [@php-5.1.6]...(--enable-pic --with-libdir=lib64 --prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib).... . . . . . . . . . . . . . . . . . . . Done

make [@php-5.1.6]...(-j 2 clean).... Done

make [@php-5.1.6]...(-j 2).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

make: *** [ext/date/lib/parse_date.lo] Error 1
make: *** Waiting for unfinished jobs....

make [@php-5.1.6]...(install).... . . . . . . . . . . . . Done

make: *** [ext/date/lib/parse_date.lo] Error 1
initfpsuexec: using apache 1.x support
PHP version file has been updated to
Executing /scripts/postbuildapache (if exists)...Done
/etc/rc.d/init.d/httpd start: httpd started
initfpsuexec: using apache 1.x support

Attempting to restart httpd

Waiting for httpd to restart....
.
.
.
.
.
.
.
.
.
.
finished.




httpd status

root 7562 0.0 0.0 27328 2828 ? Ss 10:10 0:00 /usr/local/apache/bin/httpd -DSSL




httpd started ok







Build Complete
 
Last edited:

Millar

Active Member
Dec 23, 2006
29
0
151
I made sure that was checked, i've seen that posted in other topics before.
 

linux4me

Member
Jul 14, 2007
20
1
53
Check your .htaccess for a line like this:
AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml
If it's there, comment it out:
#AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml
You probably don't need ti for that version of PHP.