The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache update in easyapache 3

Discussion in 'EasyApache' started by ribo, May 10, 2016.

  1. ribo

    ribo Active Member

    Joined:
    Oct 15, 2015
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello, i saw that in EA4 apache updated from 2.4.18 to 2.4.20 . Why was not happened the same in EA3 ?
     
  2. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,383
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Because maintaining multiple systems is multiply more difficult. EA4 is RPM based. EA3 is compile-by-source based. When you move team members from EA3 to EA4, the ability to control EA3 becomes weaker. That's why offering anything and everything is great when looking from the outside in. But from the inside, it's a nightmare. (This is also why software versions eventually go end-of-life).

    This isn't just true of EasyApache, it's true for the multiple versions of cPanel that are supported, it's true for the multiple versions of WordPress and Joomla! that their developers maintain. The more you have to maintain, unless you hire more personnel to handle that load, the more thin your personnel is spread in maintaining everything.

    This isn't the politically correct response, but doesn't mean that it's a false response.
     
  3. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    We haven't updated Apache for EA3 because there are a few bugs that are going to cause issues for cPanel systems, primarily this one: Bug 59333 – Version 2.4.20 server-status does not show page being retrieved

    We updated EA4 as usage at this time is very low, and thus very likely to impact systems. We'll probably wait until 2.4.21 before we update from 2.4.18.

    I hope this helps!
     
Loading...

Share This Page