The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Update issue...

Discussion in 'EasyApache' started by disconnect, May 16, 2006.

  1. disconnect

    disconnect Member

    Joined:
    May 4, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    maybe I am crazy, but...
    every time I use apache update to reconfigure apache with gd, imap etc (see fig 1 below for intended configure of php) I get the same output.
    if I select php 4.4.3 or 5.0.1 I still get php 4.4.1 see figure 2 for current output.

    figure 1 --- this is what I need phpinfo to answer as my configureation (or similar)

    ./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr' '--with-xml' '--with-mm' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-exif' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-iconv' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--with-mhash' '--enable-magic-quotes' '--with-mm' '--with-mysqli' '--with-mysql=/usr' '--with-openssl' '--enable-discard-path' '--with-pdflib' '--with-pear' '--with-pspell' '--enable-xslt' '--with-xslt-sablot' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--enable-wddx' '--with-xmlrpc' '--with-zlib'

    figure 2 ---- this is what it says after every rebuild for php info.

    './configure' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'

    I am checking almost everything in the apache update options but an only being left with the options hown in figure 2 and to head off the obvious - ye sI am clearing the browser cache before I reload - I can post any refrences needed

    is there anything I should clear - I have used both easy apache and whm's apache update but neither seem to output what I need. I have all teh nessacary modules installed.
    is there some build cache I need to remove or possibly a manual way of doing this through ssh?

    thanks
    disconnect
     
  2. kdarray

    kdarray Well-Known Member

    Joined:
    Apr 13, 2006
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Washington
    Force Rebuild

    There is an option on the first menu screen near the bottom to force apache to rebuild or rewrite. Try that next time you recompile.
     
  3. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    I posted about this many times. --with-swf=/usr/local/flash' is one of your problems. It does not compile cleanly therefore it will not update your version of php unless to leave FLASH out of your selection. There are two other modules that do not compile properly iwthout errors. You should be able to see which those are by running easyapache and watching the php compile.
     
  4. disconnect

    disconnect Member

    Joined:
    May 4, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks

    is the flash portion nessecary for swfs to be used on the sites???
    all of my main sites use it for navigation - it would be nightmare without it.

    Disco
     
Loading...

Share This Page