The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache update not working

Discussion in 'EasyApache' started by swampy, Mar 10, 2004.

  1. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    i need some help please i have a new box with WHM 9.0.0 cPanel 9.0.0-R44 RedHat 9 - WHM X v2.1.2 i want to update php to 4.3.4 and have gd image library installed every time i try apache update in whm it goes through the motions but never updates any help please box is 2 days old
     
  2. subn3t

    subn3t Member

    Joined:
    Sep 27, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    try to login as root, not as a user that is assignet root rights in the WHM.
     
  3. hostit1

    hostit1 Well-Known Member

    Joined:
    Jul 24, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    I am having the same problem and I am logging in as root. I have preformed the /scripts/easyapache and tried updating apache via root.

    This is weird.
     
  4. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    There are some dependency problems that need to be resolved with XFree86 first

    After doing a force re-install and ignoring dependencies for XFree86-devel the problem got solved.Re-compiling apache with php 4.3.4+GD was successful.

    hope this helps
     
  5. shawnvan

    shawnvan Registered

    Joined:
    Nov 15, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    easyapache installs 4.3.3 instead of 4.3.4

    I think I'm having the same problem. I chose PHP 4.3.4 in the easyapache script and in the WHM apache rebuild page, but either way, the script still downloaded and installed php 4.3.3. I am running WHM 2.1.2 and cPanel 9.1 S93 on RedHat 9.

    Do I have "force reinstall" like swampy did? Can you be more specific as to what needs to be reinstalled to make easyapache get PHP 4.3.4?

    shawn
     
Loading...

Share This Page