maester

Member
Jun 22, 2005
13
0
151
I was referred here by theplanet.Seems we are having problems with WHM after a mysql 5 upgrade via theplanet.They cannot fix the issue or help us so they told us to come here.The error is attached in the attachments..Thanx for any help

We have been trying to fix this issue alot lately but it still seems we have no control over our mysql and apache updates.The mysql was updated to 5 for some reason and apache just hangs on update.We tried updating to php 4.44 and its still sitting @ 4.42 after 2 days so can you please look into this issue because its caugins problems with the GD Library which is not running because the update is failing


Expires Module
Raise FD_SETSIZE to 16384 (System Wide)
Prevent Users from reading other webroots
Frontpage Module

Raise HARD_SERVER_LIMIT

Php Module

Version 4.4.4
V
Bc Math
Calendar Support
Curl (Version 7.15.3)
Curl SSL Support (Version 2.8.28)


Flash
FTP
GD (Version 2.0.15)
GetText

Imap Module (Version 2004g)
Java (must already be installed, or install will fail)

Mcrypt (Version 2.5.7)
Mhash (Version 0.8.18)
Magic Quotes

Mysql Module

Openssl Support
Discard Path

Pear
Postgresql (will break 7.2.x or earlier, please make sure you have 7.3.x or later installed)
Pspell Module
Sablot XSLT [may cause problems with chili!asp]

Sockets
Use System Mysql
Track Vars
Freetype Support


XML RPC
Zip
Zlib

PHP suEXEC Support
Report Build Errors to cPanel

Rewrite Module

SSL Module (Version 2.8.28)
suEXEC Module
--------------------------------------
(maester-09/10/2006 03:06:18):Also if this helps @ all this is from 2 diff computers one in Tennessee the other in California

Apache Build/Upgrade

Building Apache Config.....Done
Downloading and compiling apache+modules....

Fetching http://layer1.cpanel.net/buildapache.sea (0)[email protected]%...3%...4%...6%...7%...9%...11%...12%...14%...15%...17%...19%...20%...22%...23%...25%...26%...28%...30%...31%...33%...34%...36%...38%...39%...41%...42%...44%...46%...47%...49%...50%...52%...53%...55%...57%...58%...60%...61%...63%...65%...66%...68%...69%...71%...72%...74%...76%...77%...79%...80%...82%...84%...85%...87%...88%...90%...92%...93%...95%...96%...98%...99%...100%......Done

then just hangs there and stops been sitting for about 2 days to see if it would run




(mphillips-09/10/2006 03:11:37):
Are you doing this via cpanel/whm? If so, this issue is common in the newer releases.
The workaround is easy. Run /scripts/easyapache and configure the software via the text interface as opposed to the gui frontend. Strange, I know, as the gui is supposed to run the exact same script, but I haven't had any issues from the text version as of yet.
Also, try using up2date to upgrade apache itself if the cpanel/whm gui front end fails.
--------------------------------------
(maester-09/10/2006 04:12:24):We are trying to do this via root WHM Apache Update this is where it fails

But the main problem right now after running /easyapache and compiling Apache that way is that it isn't enabling CURL or SSL or Any of the above Features Listed properly for some reason.


(mphillips-09/10/2006 04:22:54):
Upon running the easyapache script, i noticed the following message:
"Your operating system's rpm update method (up2date) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed."
up2date is not connecting and is most likely the cause for this error. After re-registering and bootstraping up2date, the connection issue continues. I'm investigating this further.
--------------------------------------
(maester-09/10/2006 04:26:37):Thank you kindly for your help if you wish for me to do anything please let me know


(mphillips-09/10/2006 04:40:26):
Is there by chance a firewall running? If so, please disable it along with any ids that may be installed for troubleshooting purposes.
--------------------------------------
(maester-09/10/2006 06:09:12):my partner is the one who does all that im not sure where to go look to see if a firewall is installed
--------------------------------------
(maester-09/10/2006 06:16:45):I looked under firewalls under orbit and it says this

"
The Planet is not currently managing a firewalls on this account."

hope this is what you are talking about


(mphillips-09/10/2006 06:21:21):
True, we do not manage a firewall for you. The only managed firewalls we offer are from cisco and are a separate device completely. I'm guessing there is a software firewall running on the server preventing the connection to the rhn proxy server. Another thing you might check is that ns1.theplanet.com and ns2.theplanet.com are the namservers listed in your resolv.conf as other name servers won't have our rhn proxy dns information listed (that information is not broadcast to other dns servers outside of the planet for obvious reasons)
--------------------------------------
(maester-09/10/2006 09:22:36):Basic cPanel/WHM Setup

The following is set up

Hostname-SPECTRE.EXTREME-WEBHOSTING.COM
Primary Nameserver-NS1.EXTREME-WEBHOSTING.COM
Secondary Nameserver-NS2.EXTREME-WEBHOSTING.COM

That is the only thing that has been set in the basic for nameservers

Under the Resolver Configuration we have

Primary Resolver-70.87.78.128
Secondary Resolver-216.185.111.10

--------------------------------------
(maester-09/10/2006 09:24:29):Also under Cisco it says this

"This service is not currently available"


(bkontrath-09/10/2006 18:56:03):
It appears that your server had not been registered with our RHN server. We re-registered the server with our RHN service and now up2date appears to be working normally. In turn, cpanel should now be able to update apache normally. Please let us know if you have any further issues with the server.
--------------------------------------
(maester-09/10/2006 23:08:41):seem there is a new error I have attached the image of the error


(eharun-09/11/2006 01:15:57):
Check and see if you can still see that error now.
--------------------------------------
(maester-09/11/2006 13:12:11):Still receiving the exact same error message as the image attached


(mphillips-09/12/2006 05:47:36):
You may wish to send a bug report to the cPanel group.
http://www.cpanel.net
 

Attachments

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,221
4
193
Minneapolis, MN
maester said:
I was referred here by theplanet.Seems we are having problems with WHM after a mysql 5 upgrade via theplanet.They cannot fix the issue or help us so they told us to come here.The error is attached in the attachments. Thanx for any help
It would be really diificult to troubleshoot such a problem without looking into your server. Now, you have two options, either to submit a technical support request with the cPanel technical support, or seek professional help.