Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

apache using like 50% memory

Discussion in 'EasyApache' started by Malik, Jan 26, 2005.

  1. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    151
    Hi.
    on one of my servers, apache is apparently hogging up 50% ish of the memory. normally it hangs around 60-70% used but after i restart apache, the memory usage drops down to 30% roughly.

    ?
     
  2. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    it is usually due to the number of Apache processes. in your case it seems very high.

    I suggest changing KeepAlive On to KeepAlive Off in /usr/local/apache/conf/httpd.conf and restarting your apache.
     
  3. Malik

    Malik Member

    Joined:
    Dec 16, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    151
    I have made so.
    Now memory comes to an end more slowly, but all the same in day of 70 %-80 % of memory is used.

    Current Time: Friday, 28-Jan-2005 20:57:25 MSK
    Restart Time: Friday, 28-Jan-2005 07:15:33 MSK
    Parent Server Generation: 0
    Server uptime: 13 hours 41 minutes 52 seconds
    Total accesses: 283570 - Total Traffic: 1.9 GB
    CPU Usage: u2956.26 s372.24 cu120.24 cs372.78 - 7.75% CPU load
    5.75 requests/sec - 39.7 kB/second - 6.9 kB/request
    11 requests currently being processed, 30 idle servers

    Server Load 0.57 (1 cpu)
    Memory Used 75.5 %

    After restart apache used memeory down to 30%.
    And then again starts to rise used memory.
     
  4. Webjunkie

    Webjunkie Active Member
    PartnerNOC

    Joined:
    May 1, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    156
    I'm seeing similar things on my server. I'm curious to find out what might be causing this...
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice