The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache version is wrong

Discussion in 'EasyApache' started by dravenlon, Jan 13, 2007.

  1. dravenlon

    dravenlon Member

    Joined:
    Jan 11, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    IL, USA
    in CPanel it says
    Code:
    Apache version	1.3.37 (Unix)
    
    but in WHM it says..
    Code:
    Apache Core        2.2.4
    

    How can I get CPanel the proper apache version?
     
  2. mOdY

    mOdY Well-Known Member

    Joined:
    Dec 25, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Well,

    I think WHM get it's version live by issuing "httpd -v" command and getting it's output or at the compiling time and caching it into some file, However cPanel for users works in a different way, it gets it's output from /home/user/.cpanel-datastore/_usr_local_apache_bin_httpd_-v

    So, the following code should get care of having this file for all clients be updated.


    #!/bin/bash

    cd /var/cpanel/users
    for user in *
    do
    /usr/local/apache/bin/httpd -v > /home/$user/.cpanel-datastore/_usr_local_apache_bin_httpd_-v
    done
    exit

    #end#


    Hope it helps :)
     
Loading...

Share This Page