Apache vhosts are not segmented

celiac101

Well-Known Member
Dec 19, 2012
85
1
8
cPanel Access Level
Website Owner
Hello,

I am getting this warning when I run a security scan:
  • Apache vhosts are not segmented or chroot()ed. Enable “Jail Apache” in the “Tweak Settings” area, and change users to jailshell in the “Manage Shell Access” area.
My question is, if I am running PHP-FPM service for Apache should I still install mod_ruid2 and then Jail Apache Virtual Hosts? Are they compatible, and in my case, necessary? Again, I run all sites on the server.

Last, if the answer is that I should install this to beef up security, will this slow down my site speed?
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello @celiac101,

There's an existing thread on this topic at:

Apache vhosts are not segmented or chroot()ed

Note that internal case (SWAT-733) open to ensure that specific Security Advisor alert reflects the fact that Mod_Ruid2 is required in order to use the "Jail Apache" option in "WHM >> Tweak Settings".

Let me know if you have additional questions.

Thanks!