The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache will not compile..md5 error

Discussion in 'EasyApache' started by I Love Jesus, Dec 25, 2004.

  1. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    cpu load is high...strange process

    I received an email from anonymous...

    "A worm using a phpbb vulnerability is trying to infect my system coming from IP xx...."

    Well, I ran rkhunter and chkrootkit and both came back fine. Are there any others I can run to check for such a worm?

    Specs:
    RHE 3.3
    Cpanel 9.9.9 R-14
    PHP v 4.3.1.0

    I believe the worm (if there is one) is running as nobody. I did notice a high load in server status for nobody user.

    Code:
    User Domain %CPU %MEM Mysql Processes 
    nobody  95.24 14.34 0.0 
    Top Process %CPU 96.3 /hsphere/shared/apache/bin/httpd -DSSL 
    Top Process %CPU 96.2 /hsphere/shared/apache/bin/httpd -DSSL 
    Top Process %CPU 96.0 /hsphere/shared/apache/bin/httpd -DSSL 
    
    Kernel Info:
    Linux server.myserver.com 2.4.21-4.0.1.ELsmp #1 SMP Thu Oct 23 01:27:36 EDT 2003 i686 i686 i386 GNU/Linux
    Please give me a hand here.
     
  2. fikse

    fikse Well-Known Member

    Joined:
    May 10, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    do a search in your filesystem for m1ho2of

    thats the perl script worm that is installed as a result of a phpbb/php exploit.....
     
  3. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    ok logged in root and did "locate m1ho2of" and got nothing.

    Any other suggestions?

    Thanks for your help
     
  4. fikse

    fikse Well-Known Member

    Joined:
    May 10, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    I'm not sure if a perl script will show up as a program using locate....

    try:

    find / -name m1ho2of
     
  5. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    httpd failed :(

    httpd failed after updating apache to 4.3.1.0 and cpanel to 9.9.9 R14.

    I did:

    /scripts/easyapache
    /scripts/upcp
    /scripts/installzendopt (necessary after upgrading to 4.3.1.0)
    /scripts/updatenow

    configtest shows "syntax ok" for httpd

    restarting apache in whm says:

    httpd has failed, please contact the sysadmin.

    When updating apache, I had all defaults checkmarked too.

    What to do?
     
  6. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    [Sun Dec 26 08:48:49 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 08:49:37 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 08:50:02 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 08:50:03 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:01:38 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:01:51 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:02:22 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:03:03 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:03:18 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:04:37 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:06:22 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:06:31 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:09:32 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:14:43 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:17:19 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:20:19 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:20:45 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:21:32 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:21:43 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:25:53 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:28:47 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:31:40 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Dec 26 09:34:27 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?[Sun Dec 26 09:34:27 2004] [crit] (98)Address already in use: mak$

    [Sun Dec 26 09:35:47 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
     
  7. firexit

    firexit Active Member

    Joined:
    Nov 4, 2004
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    8
    i had the same prob

    i had the same prob !
    i think its llinked to something in that not all the modules can work 2gether.
    weird.
     
  8. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    its not the modules because this is the same config i have on my other servers


    also,..mmcache is installed if that helps

    I followed uninstall instructions found on other thread but it wasn't 100% compatible to what I have (line in php.ini for instance). Anyways, reinstalled mmcache re-compiled apache again, same issue
     
  9. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Ok, removed lines for mmcache in php.ini and reinstalled zend. Load is extremely high now (spikes instantly) after graceful reboot (but apache working now). Removed anything mmcache related also (directory,files)

    It shoots over to 90% cpu usage! :(

    I have no idea why. The config is no different from any other servers I have.

    CPU processes are all normal in WHM's "show current cpu usage"

    cpu/memory/mysql stats

    Code:
    User Domain %CPU %MEM Mysql Processes 
    root  10.22 4.84 2.0 
    Top Process %CPU 55.0 /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/cc1 -quiet -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mysql/libmysql -Iext/mysql/ -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mysql/ -I/home/cpapachebuild/buildapache/php-4.3.10/include -I/home/cpapachebuild/buildapache/php-4.3.10/main -I/home/cpapachebuild/buildapache/php-4.3.10 -I/home/cpapachebuild/buildapache/php-4.3.10/Zend -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/imap -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/mbregex -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl/mbfl -I/usr/local/flash/include -I/home/cpapachebuild/buildapache/php-4.3.10/ext/xml/expat -I/home/cpapachebuild/buildapache/php-4.3.10/TSRM -D__GNUC__3 -D__GNUC_MINOR__3 -D__GNUC_PATCHLEVEL__3 -DPHP_ATOM_INC -DPIC /home/cpapachebuild/buildapache/php-4.3.10/ext/mysql/php_mysql.c -quiet -dumpbase php_mysql.c -auxbase-strip ext/mysql/php_mysql lo -g -O2 -fPIC -o /tmp/ccLCPibc.s 
    Top Process %CPU 42.0 /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/cc1 -quiet -Iext/zlib/ -I/home/cpapachebuild/buildapache/php-4.3.10/ext/zlib/ -I/home/cpapachebuild/buildapache/php-4.3.10/include -I/home/cpapachebuild/buildapache/php-4.3.10/main -I/home/cpapachebuild/buildapache/php-4.3.10 -I/home/cpapachebuild/buildapache/php-4.3.10/Zend -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/imap -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/mbregex -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl/mbfl -I/usr/local/flash/include -I/home/cpapachebuild/buildapache/php-4.3.10/ext/xml/expat -I/home/cpapachebuild/buildapache/php-4.3.10/TSRM -D__GNUC__3 -D__GNUC_MINOR__3 -D__GNUC_PATCHLEVEL__3 -DPHP_ATOM_INC -DPIC /home/cpapachebuild/buildapache/php-4.3.10/ext/zlib/zlib.c -quiet -dumpbase zlib.c -auxbase-strip ext/zlib/zlib lo -g -O2 -fPIC -o /tmp/ccHer1BH.s 
    Top Process %CPU 39.0 /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/cc1 -quiet -IZend/ -I/home/cpapachebuild/buildapache/php-4.3.10/Zend/ -I/home/cpapachebuild/buildapache/php-4.3.10/include -I/home/cpapachebuild/buildapache/php-4.3.10/main -I/home/cpapachebuild/buildapache/php-4.3.10 -I/home/cpapachebuild/buildapache/php-4.3.10/Zend -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/imap -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/mbregex -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl -I/home/cpapachebuild/buildapache/php-4.3.10/ext/mbstring/libmbfl/mbfl -I/usr/local/flash/include -I/home/cpapachebuild/buildapache/php-4.3.10/ext/xml/expat -I/home/cpapachebuild/buildapache/php-4.3.10/TSRM -D__GNUC__3 -D__GNUC_MINOR__3 -D__GNUC_PATCHLEVEL__3 -DPHP_ATOM_INC /home/cpapachebuild/buildapache/php-4.3.10/Zend/zend_operators.c -quiet -dumpbase zend_operators.c -auxbase-strip Zend/zend_operators o -g -O2 -o /tmp/ccL93MDa.s 
    user domain.com 0.93 84.78 109.0 
    
     
  10. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Ok, status back to normal, trying to recompile apache one more time...


    root@host1 [~]# /scripts/easyapache
    --11:09:02-- http://layer1.cpanel.net/buildapache.sea
    => `buildapache.sea'
    Resolving layer1.cpanel.net... done.
    Connecting to layer1.cpanel.net[69.72.164.150]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 133,713 [text/plain]

    100%[====================================>] 133,713 476.57K/s ETA 00:00

    11:09:02 (476.57 KB/s) - `buildapache.sea' saved [133713/133713]

    Creating directory buildapache
    Verifying archive integrity...curl: (7) Failed to connect to 361 IP number 1: In
    valid argument
    Error in MD5 checksums: d41d8cd98f00b204e9800998ecf8427e is different from 6394d
    98fc8e292746d2374861ecb075a
    Waiting for httpd to restart..............finished.

    root 16459 0.7 1.1 14060 5968 ? S 11:09 0:00 /usr/local/apache
    /bin/httpd -DSSL

    httpd started ok



    ??? Suddenly?
     
  11. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    apache wont' compile

    trying to recompile apache with php 4.3.1.0


    root@host1 [~]# /scripts/easyapache
    --11:09:02-- http://layer1.cpanel.net/buildapache.sea
    => `buildapache.sea'
    Resolving layer1.cpanel.net... done.
    Connecting to layer1.cpanel.net[69.72.164.150]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 133,713 [text/plain]

    100%[====================================>] 133,713 476.57K/s ETA 00:00

    11:09:02 (476.57 KB/s) - `buildapache.sea' saved [133713/133713]

    Creating directory buildapache
    Verifying archive integrity...curl: (7) Failed to connect to 361 IP number 1: In
    valid argument
    Error in MD5 checksums: d41d8cd98f00b204e9800998ecf8427e is different from 6394d
    98fc8e292746d2374861ecb075a
    Waiting for httpd to restart..............finished.

    root 16459 0.7 1.1 14060 5968 ? S 11:09 0:00 /usr/local/apache
    /bin/httpd -DSSL

    httpd started ok


    Anyone know why?
     
  12. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    anyone else having trouble updating apache? cpanel?

    Anyone here having trouble updating apache or cpanel?

    I tested at least 4-5 servers and same thing. It isn't my DC network because everything is up.

    Please confirm
     
  13. simplybe

    simplybe Well-Known Member

    Joined:
    Nov 29, 2002
    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    16
    I had problems on 3 servers, all 3 just froze when updating cpanel. Restarting cpanel and updating via ssh seems to solve the problem.
     
  14. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    trying to recompile apache and got this


    root@host1 [~]# /scripts/easyapache
    --11:09:02-- http://layer1.cpanel.net/buildapache.sea
    => `buildapache.sea'
    Resolving layer1.cpanel.net... done.
    Connecting to layer1.cpanel.net[69.72.164.150]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 133,713 [text/plain]

    100%[====================================>] 133,713 476.57K/s ETA 00:00

    11:09:02 (476.57 KB/s) - `buildapache.sea' saved [133713/133713]

    Creating directory buildapache
    Verifying archive integrity...curl: (7) Failed to connect to 361 IP number 1: In
    valid argument
    Error in MD5 checksums: d41d8cd98f00b204e9800998ecf8427e is different from 6394d
    98fc8e292746d2374861ecb075a
    Waiting for httpd to restart..............finished.

    root 16459 0.7 1.1 14060 5968 ? S 11:09 0:00 /usr/local/apache
    /bin/httpd -DSSL

    httpd started ok


    I ran:
    /scripts/cleanmd5
    /scripts/upcp --force
    /scripts/updatenow
    /scripts/easyapache

    copied buildapache.sea from a successfully updated server (today) and still same error.
    copied buildapache.sea from cpanel layer1 (site) and still same error :(

    Anyone know what's happening here?
     
    #14 I Love Jesus, Dec 26, 2004
    Last edited: Dec 26, 2004
  15. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    I am also having this problem.
     
  16. Joshfrom

    Joshfrom Well-Known Member

    Joined:
    Jun 3, 2003
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    White Haven, PA, US
    Just merged together a whole bunch of threads on the same topic all by "I Love Jesus".

    Try to contain your thoughts on a subject to one thread.
     
  17. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    sorry...the first was originally a different problem so I didnt' want to confuse up the thread.

    perhaps you can help with this matter josh? Please I've been working on this all day :(
     
  18. carlos

    carlos Registered

    Joined:
    Apr 7, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    remove php.ini and recompile apache using easyapache.

    That will fix it.
     
  19. sv1

    sv1 Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    My problem is it never actually updates. It appears to run and install everything, restars fine but the version does not change nor the mods
     
Loading...

Share This Page