The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache won't restart !

Discussion in 'EasyApache' started by northtrex, Apr 3, 2005.

  1. northtrex

    northtrex Active Member

    Joined:
    Feb 26, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I have noticed since a couple of weeks when creating or deleting an account from WHM, apache won't restart. I have to do it manually. I also found that when I'm moving an IP to another, apache won't restart too. It causing some downtime and it would be very appreciated if someone here have any idea about that. Does it could be the newest version of Cpanel causing that because it was not doing that before ? I have do a cleanup of apache config file and error logs file but always getting the same problem. Thank in advance !
     
  2. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    When apache won't restart from whm, do you see any problems reported within the logs or the whm page?

    Which distro are you running? Have you checked that you don't have an rpm install of httpd as well as the apache src, have seent that cause issues especially with ssl installs, as the service that gets restarted was the rpm installation of httpd.

    # rpm -qa | grep httpd

    for linux, if you have httpd installed, then backing up your httpd.conf and removing the rpm would help.
     
  3. Worelock

    Worelock Active Member

    Joined:
    Mar 23, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    More information on this - Long post

    Hello DigitalN,

    I can elaborate a bit further on this issue.
    We are running the following:

    WHM 10.0.0 cPanel 10.1.0-C4
    RedHat Enterprise 3 i686 - WHM X v3.1.0

    Apache built as follows:
    Apache/1.3.33 (Unix) mod_ssl/2.8.21 OpenSSL/0.9.7a mod_throttle/3.1.2 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.10 FrontPage/5.0.2.2634a

    I have searched the logs at the points where the server fails and everytime it does this is the result in the error_log file.

    [Sun Apr 3 18:29:35 2005] [notice] SIGUSR1 received. Doing graceful restart
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    [Sun Apr 3 18:33:14 2005] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Apr 3 18:33:14 2005] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.21 OpenSSL/0.9.7a mod_throttle/3.1.2 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.10 FrontPage/5.0.2.2634a configured -- resuming normal operations
    [Sun Apr 3 18:33:14 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Sun Apr 3 18:33:14 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)

    Hope this sheds some light on the issue.

    Paul
     
Loading...

Share This Page