The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache Wont Start - Urgent

Discussion in 'EasyApache' started by PaulioTheGreat, Jun 1, 2005.

  1. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hey, my server has been down since monday and i cant find a cure, ive been reading the forums and ive run a few scripts etc... in ssh but nothings happening if it helps here it is.


    Code:
    root@ethos [~]# /etc/init.d/httpd start
    httpd: bad group name haxorgam
    /etc/init.d/httpd start: httpd could not be started
    root@ethos [~]# tail -30 /etc/httpd/logs/error_log
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/(  Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/)  Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/, Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/. Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/; Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/[  Symbol.gif
    [Mon May 30 19:52:45 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/] Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/Back Slash Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/Forward Slash Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/Question mark  Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/Two dots above each other Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/- Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/Pictures/writing/Symbols Punctuation/! Symbol.gif
    [Mon May 30 19:52:46 2005] [error] [client 62.252.64.19] File does not exist: /home/habbari/public_html/404.shtml
    [Mon May 30 19:52:53 2005] [error] [client 213.148.183.209] File does not exist: /home/gta/public_html/images/conmainbak.jpg
    [Mon May 30 19:52:53 2005] [error] [client 213.148.183.209] File does not exist: /home/gta/public_html/404.shtml
    [Mon May 30 19:52:54 2005] [notice] SIGUSR1 received.  Doing graceful restart
    httpd: bad group name haxorgam
    root@ethos [~]# 

    Please Reply ASAP, as my server has been down for a while and im getting it in the ear :)

    Thanks In Advance,

    Paul

    EDIT: ITS ONLY APACHE THATS DOWN, SORRY MISSED THAT PART OUT - IM A SILLY PRAT :)
     
    #1 PaulioTheGreat, Jun 1, 2005
    Last edited: Jun 1, 2005
  2. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Check the relevant section in your httpd.conf, it should say

    User nobody
    Group nobody

    Also the group name 'haxorgam' sounds pretty suspicious, don't you think?
     
  3. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    yes i thought the same but ive spoken to the reseller and the people that use it have no access to cpanel or anything, they just use the site. ive checked that, its set to nobody.


    this may sound noobish and forgive me if it is, is there anyway to recomplie httpd.conf? making all the setting to what they should be.?

    thanks Paul
     
    #3 PaulioTheGreat, Jun 1, 2005
    Last edited: Jun 1, 2005
  4. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I'm not sure what you're saying, is haxorgam an account on your server or do you have no idea where the group name is from?

    In which sections of your httpd.conf did you find 'haxorgam' ?

    Did you check if the user haxorgam exists in /etc/group ?
     
  5. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1

    haxorgam is an account on my server

    Code:
    <VirtualHost 209.67.217.226>
    ServerAlias www.haxorgaming.jd-tech.net haxorgaming.jd-tech.net
    ServerAdmin webmaster@haxorgaming.jd-tech.net
    DocumentRoot /home/haxorgam/public_html
    BytesLog domlogs/haxorgaming.jd-tech.net-bytes_log
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/haxorgam/:/usr/lib/php:/usr/local/lib/php:/$
    </IfModule>
    ServerName www.haxorgaming.jd-tech.net
    ScriptAlias /cgi-bin/ /home/haxorgam/public_html/cgi-bin/
    User haxorgam
    Group haxorgam
    CustomLog domlogs/haxorgaming.jd-tech.net combined
    </VirtualHost>
    
    
    
    
    <VirtualHost 209.67.217.226>
    ServerAlias www.macos.haxorgaming.com macos.haxorgaming.com
    ServerAdmin webmaster@macos.haxorgaming.com
    DocumentRoot /home/macos/public_html   
    BytesLog domlogs/macos.haxorgaming.com-bytes_log
    ServerName www.macos.haxorgaming.com
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/macos:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    User macos
    Group macos  
    CustomLog domlogs/macos.haxorgaming.com combined
    ScriptAlias /cgi-bin/ /home/macos/public_html/cgi-bin/
    </VirtualHost>
    
    and is etc/group is:

    haxorgamam:x:32061:haxorgam


    should this be:

    haxorgam:x:32061:haxorgam ?
     
  6. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Correct section should look like this :>>>>

    <VirtualHost 209.67.217.226>
    ServerAlias www.haxorgaming.jd-tech.net haxorgaming.jd-tech.net
    ServerAdmin webmaster@haxorgaming.jd-tech.net
    DocumentRoot /home/haxorgam/public_html
    BytesLog domlogs/haxorgaming.jd-tech.net-bytes_log
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/haxorgam/:/usr/lib/php:/usr/local/lib/php:/$
    </IfModule>
    ServerName www.haxorgaming.jd-tech.net
    ScriptAlias /cgi-bin/ /home/haxorgam/public_html/cgi-bin/
    User haxorgamam
    Group haxorgamam

    CustomLog domlogs/haxorgaming.jd-tech.net combined
    </VirtualHost>
     
  7. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Very likely.
     
  8. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    ive tryed that but still nothing, i tryed changing /etc/group part the haxorgamam to haxorgam too and still nothing, also on whm the account name for haxorgaming is haxorgam.
     
  9. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Well, that's strange. If haxorgam is listed in /etc/group then I don't understand where the error comes from.

    Did you perhaps made changes manually in the group or user files? I don't see how haxorgam can change into haxorgagam otherwise.

    You could comment out the relevant vhost lines in httpd.conf, then restart apache. And then try to fix the haxorgam issue.

    Or you could try recreating the account (make sure you have a good backup first)
     
  10. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    we are getting there ! ive changed all haxorgamam entries to haxorgam and apache is almost working - although showing as failed, sites with php arent working, they are coming up with download dialog boxes
     
    #10 PaulioTheGreat, Jun 1, 2005
    Last edited: Jun 1, 2005
  11. PaulioTheGreat

    Joined:
    Sep 25, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    all sorted, i rebuilt apache and its up and php is fine too, thanks guys :) your great lol
     
  12. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    In case you're not running phpsuexec, do you have these 2 lines somewhere in your httpd.conf ?

    LoadModule php4_module libexec/libphp4.so

    AddModule mod_php4.c

    You can try rebuilding apache also.
     
    #12 jamesbond, Jun 1, 2005
    Last edited: Jun 1, 2005
Loading...

Share This Page