The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apache2 failing after account created

Discussion in 'EasyApache' started by JonathanLIVE, Oct 16, 2007.

  1. JonathanLIVE

    JonathanLIVE Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    I have a number of servers failing now when a cpanel account is created under a reseller. All are running php5 apache2.2 and build WHM 11.11.0 cPanel 11.15.0-C17665

    Looking at the httpd.conf it looks like the account information is being entered at the very end of the config, rather than just before all the variables that should be at the end.

    All the configs look fine otherwise.. I don't know why cpanel is putting the details for apache at the end of the http.conf

    Has anybody experienced this? what is the fix?

    Thanks
     
  2. rustelekom

    rustelekom Well-Known Member
    PartnerNOC

    Joined:
    Nov 13, 2003
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    moscow
    check config tempaltes for apache2. probably something wrong there.
     
  3. JonathanLIVE

    JonathanLIVE Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Sorry to sound like such a complete newbie.. but I only have a few weeks of experience with apache2 and it certainly is different from 1.3.. where do I find those? :)
     
  4. JonathanLIVE

    JonathanLIVE Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    For anyone else who has this issue and would like to know where the template file is located it is as follows:

    The file I edit is this: /var/cpanel/templates/apache2/vhost.default

    Originally, it have a space, which was causing the problems, which I removed:

    Original:

    <VirtualHost[% FOREACH ipblock IN vhost.ips %][% ipblock.ip %] :[% ipblock.port %][% END %]>

    Edited:

    <VirtualHost[% FOREACH ipblock IN vhost.ips %][% ipblock.ip %]:[% ipblock.port %][% END %]>

    After a lot of testing, a day later, Russell at Cpanel support finally solved the problem.

    Perhaps for others this will save time if you run into the same situation.

    Jonathan
     
    #4 JonathanLIVE, Oct 17, 2007
    Last edited: Oct 17, 2007
  5. JonathanLIVE

    JonathanLIVE Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    I spoke too soon.. this did NOT fix the issue.. I am still experiencing the same error.. does anybody else have any other suggestions.. now been 24 hours down because of this issue.
     
  6. JonathanLIVE

    JonathanLIVE Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Matt at support finally found the source of the issue.

    /var/cpanel/mainips/

    This is where the reseller IPs are stored in separate files.

    In order to setup all the reseller accounts across 20 servers I devised a way to simply edit this file via a bash script, but the IPs I imported were from Excell which carried with it a space at the end of the IP. Cpanel has no sanity checks so this space just went straight into apache and anywhere else the IP was referenced.

    SOOOO.. if you are dealing with dozens of servers and want to go about setting up resellers the fast way like I was.. rather than point and clicking yourself into an early grave with WHM, just be careful with an spaces :)

    Thanks to Matt for confirming the source of the issue where others passed it by.

    Jonathan
     
Loading...
Similar Threads - apache2 failing account
  1. opentoe
    Replies:
    4
    Views:
    377
  2. jettdigitals
    Replies:
    6
    Views:
    449

Share This Page