Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

apache_php_fpm failed permanently

Discussion in 'EasyApache' started by gnetwork-cp, Dec 3, 2017.

Tags:
  1. gnetwork-cp

    gnetwork-cp Member

    Joined:
    Mar 1, 2016
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Since making a small adjustment in MultiPHP Manager - the Pool options of php-fpm - the following service has failed permanently:
    apache_php_fpm

    I can't get it back, having removed it and re-installed in EA4. I also set defaults in /var/cpanel/ApachePHPFPM/system_pool_defaults.yaml
    Rebooted several times... still apache_php_fpm service is down.

    When I go to MultiPHP Manager, I see this notice:

    Your system contains an old PHP-FPM configuration. To update your PHP-FPM configuration, read our Configure or Disable PHP-FPM with User Pools for EasyApache 4 documentation.
    [Acknowledge]

    So I visited that page, but doesn't help. Getting email notices every 5 min.
    All my settings look ok.

    Need help to get apache_php_fpm going again.

    Additional info: apache_php_fpm service appears UP when I turn php-fpm OFF for the domains, but when I turn it on, the apache_php_fpm service goes DOWN. Either way page loads result in 500/503 error, currently only cached pages (mod_cache_disk) work.
     
    #1 gnetwork-cp, Dec 3, 2017
    Last edited: Dec 3, 2017
  2. gnetwork-cp

    gnetwork-cp Member

    Joined:
    Mar 1, 2016
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I needed to get it working, so opened a Ticket and it was solved quickly after.

    The issue was that the PHP-FPM configuration files contained an outdated directive that was causing PHP-FPM to not start up.
    To address this issue, I removed the "php_admin_value_error_reporting" line from the /var/cpanel/ApachePHPFPM/system_pool_defaults.yaml file. I then rebuilt the Apache PHP-FPM configuration files with "/scripts/php_fpm_config --rebuild".
     
    cPanelMichael likes this.
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,700
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see the issue was solved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice