The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

apt-get issues

Discussion in 'General Discussion' started by heath, Dec 16, 2007.

  1. heath

    heath Member

    Joined:
    Jul 11, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to use apt-get to install some modules. When I try to install anything, it reports:

    You might want to run `apt-get --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    bandmin: Depends: perl(bandmin.conf) but it is not installable
    Depends: perl(bmversion.pl) but it is not installable
    Depends: perl(services.conf) but it is not installable
    mod_authz_ldap: Depends: httpd-mmn (= 20020903)
    mod_python: Depends: httpd (>= 2.0.40)
    Depends: httpd-mmn (= 20020903)
    perl-DBD-MySQL: Depends: libmysqlclient.so.10
    php-mysql: Depends: libmysqlclient.so.10
    Depends: php (= 4.3.2-24.ent)
    E: Unmet dependencies. Try using --fix-broken.

    I haven't yet run --fix-broken because I'm worried it may cause issues on my server since I already have Apache 3 installed as well as PHP/MySQL.

    Any ideas what I should do at this point, or am I to avoid using apt-get with cPanel?
     
  2. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    it would help greatly if you stated which OS you are using, if it is RHEL or CentOS, is there a particular reason why you are using apt instead of yum?
     
  3. heath

    heath Member

    Joined:
    Jul 11, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, my mistake. I'm using RHEL3. I don't have yum installed because I was always more familiar with apt-get on other systems.
     
  4. heath

    heath Member

    Joined:
    Jul 11, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I'm actually trying to install subversion. I've also tried this:

    http://www.cpwiki.org/wiki/How-To:_Installing_SVN_in_cPanel

    But again, problems requiring httpd when I have Apache3 installed:

    error: Failed dependencies:
    httpd >= 2.0.46 is needed by mod_dav_svn-1.2.3-1
    libapr-0.so.0 is needed by subversion-1.2.3-1
    libaprutil-0.so.0 is needed by subversion-1.2.3-1
    Suggested resolutions:
    /var/spool/up2date/httpd-2.0.46-63.ent.i386.rpm
     
  5. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    i dont think you will be able to get around the httpd requirement with apt in this instance as easyapache complies from source instead of using pre-made rpm packages, therefore apt is not aware that apache exists on the system.

    I'm not entirely familiar with apt, is there a skip-dependancies flag you can add when you call apt-get install?

    It certainly isnt wise to --fix-broken-install, that will do far more harm than good.

    I would strongly suggest compiling subversion from source, as this is bound to be the least problematic way of getting it installed.
     
Loading...

Share This Page