The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Are these WHM MX settings correct for using Google as email server?

Discussion in 'E-mail Discussions' started by jerrygarciuh, Apr 17, 2013.

  1. jerrygarciuh

    jerrygarciuh Member

    Joined:
    Feb 5, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have just edited this post to use real domain name after confusing some readers:

    /etc/localdomains does not have the domain but it does have a subdomain par5.egolfplan.com

    /etc/remotedomains does have the domain egolfplan.com

    On WHM MX page:

    Email Routing for egolfplan.com is set to "Automatically Detect Configuration: (recommended)"

    There are 5 records

    10 ASPMX.L.GOOGLE.COM

    20 ALT1.ASPMX.L.GOOGLE.COM

    30 ALT2.ASPMX.L.GOOGLE.COM

    40 ASPMX2.GOOGLEMAIL.COM

    50 ASPMX3.GOOGLEMAIL.COM

    These values are per Configuring Your MX Records: WHM - Google Apps Help

    Of concern is the fact that saving those MX records gets me this message:

    Reconfiguring Mail Routing:
    REMOTE MAIL EXCHANGER: This server will NOT serve as a mail exchanger for egolfplan.com's mail.: This configuration has been automatically detected based on your mx entries.


    I also have a CNAME (in normal DNS Zone Edit page in WHM) for mail which has value ghs.googlehosted.com. but the address http://mail.egolfplan.com does not resolve and that record has been in place several days.

    When I use PHP to send an email to someuser@egolfplan.com and then check /var/log/exim_mainlog I see this:

    2013-04-17 14:21:41 cwd=/home/egolfplan/public_html 3 args: /usr/sbin/sendmail -t -i
    2013-04-17 14:21:41 1USXvJ-000467-Lv <= someuser@par5.egolfplan.com U=egolfplan P=local S=789 id=3f9989886b364d9fdc9e2e5a70156cce@egolfplan.com T="egolfplan Contact Message" for someuser@egolfplan.com
    2013-04-17 14:21:41 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1USXvJ-000467-Lv
    2013-04-17 14:21:41 1USXvJ-000467-Lv SMTP connection outbound 1366226501 1USXvJ-000467-Lv egolfplan.com someuser@egolfplan.com
    2013-04-17 14:21:41 1USXvJ-000467-Lv lowest numbered MX record points to local host: egolfplan.com
    2013-04-17 14:21:41 1USXvJ-000467-Lv == someuser@egolfplan.com R=lookuphost defer (-1): lowest numbered MX record points to local host
    2013-04-17 14:21:41 1USXvJ-000467-Lv Frozen
     
    #1 jerrygarciuh, Apr 17, 2013
    Last edited: Apr 17, 2013
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Whois info of domain barbaz.com says that the nameservers are:
    NS1.DOMAINRECOVER.COM
    NS2.DOMAINRECOVER.COM

    this is what tose nameservers tell about the MX records:

    root@finn1 [~]# nslookup
    > server NS1.DOMAINRECOVER.COM
    Default server: NS1.DOMAINRECOVER.COM
    Address: 66.45.232.66#53
    > set Q=MX
    > barbaz.com
    Server: NS1.DOMAINRECOVER.COM
    Address: 66.45.232.66#53

    barbaz.com mail exchanger = 20 mxs2.domainrecover.com.
    barbaz.com mail exchanger = 10 mxs1.domainrecover.com.

    See what Intodns tells about your domain:
    intoDNS: barbaz.com - check DNS server and mail server health
     
  3. jerrygarciuh

    jerrygarciuh Member

    Joined:
    Feb 5, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I was using foo bar and baz as replacements for the real domain name. This is common practice in Perl coder circle but perhaps not here? The actual domain is egolfplan.com
     
  4. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    I don't remember seeing that domain "replacement".
    Anyway...

    whois info of the domain tells that the nameservers of egolfplan.com are:
    NS1.SOFTLAYER.COM
    NS2.SOFTLAYER.COM

    this is what those nameservers tell about the MX records:
    root@finn1 [~]# nslookup
    > server NS1.SOFTLAYER.COM
    Default server: NS1.SOFTLAYER.COM
    Address: 67.228.254.4#53
    Default server: NS1.SOFTLAYER.COM
    Address: 2607:f0d0:0:f:1::1#53
    > set Q=MX
    > egolfplan.com
    Server: NS1.SOFTLAYER.COM
    Address: 67.228.254.4#53

    egolfplan.com mail exchanger = 10 mail.egolfplan.com.

    then if we see what your server tells:
    root@finn1 [~]# nslookup
    > server 67.228.22.163
    Default server: 67.228.22.163
    Address: 67.228.22.163#53
    > set Q=MX
    > egolfplan.com
    Server: 67.228.22.163
    Address: 67.228.22.163#53

    egolfplan.com mail exchanger = 50 aspmx3.googlemail.com.
    egolfplan.com mail exchanger = 10 aspmx.l.google.com.
    egolfplan.com mail exchanger = 20 alt1.aspmx.l.google.com.
    egolfplan.com mail exchanger = 30 alt2.aspmx.l.google.com.
    egolfplan.com mail exchanger = 40 aspmx2.googlemail.com.

    So, in the DNS zone of the domain egolfplan.com in your server you have the google MX records, but because the nameservers are pointing elsewhere (i.e. NS1.SOFTLAYER.COM & NS2.SOFTLAYER.COM) that DNS zone is not used and it has no effect whatsoever.
     
  5. jerrygarciuh

    jerrygarciuh Member

    Joined:
    Feb 5, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for the reply! What is the remedy? SoftLayer is the dedicated server provider. I am using their DNS servers for the domain egolfplan.com
     
  6. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Contact your dedicated server provider as they will help you to set the correct MX records for your domain.
     
  7. jerrygarciuh

    jerrygarciuh Member

    Joined:
    Feb 5, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    storm- the domain uses Google for email though, not the dedicated server. Mail is remotely hosted.
     
  8. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Your domain's nameservers are:
    NS1.SOFTLAYER.COM
    NS2.SOFTLAYER.COM

    If you want to change your domain's MX entries (or anything in your domain's DNS settings) it has to be done in those nameservers above, not anywhere else.
     
  9. jerrygarciuh

    jerrygarciuh Member

    Joined:
    Feb 5, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    OK, thanks guys. I'll get in touch with admins for SoftLayer. I appreciate your help and time!
     
Loading...

Share This Page