The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

aspell crashing my box.

Discussion in 'General Discussion' started by sneader, Feb 8, 2005.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I'm having a problem with a process called "aspell" running by user "cpanel" and I'm not sure what it's used for, but it's killing my box.

    The command (/usr/bin/aspell -a -d american -H) is running under the cpanel user and it gobbles up RAM until the box dies.

    We can reproduce this behavior with this: echo "<html><body>blah lindner" | /usr/bin/aspell -a -d american -H

    The exact command that was using over 1.2G of memory before we killed it last time was:

    /usr/bin/aspell -a -d american -H

    Any ideas or pointers would be appreciated.

    - Scott
     
    #1 sneader, Feb 8, 2005
    Last edited: Feb 8, 2005
  2. abused1

    abused1 Member

    Joined:
    Jan 19, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    We are running into this problem daily on multiple servers. Every time we come across it we disable aspell for that server.

    To disable it you can do chmod 0 /usr/bin/aspell



    Does anyone have a workaround that does not require it being disabled? And does anyone have an idea why this seems to be a recent problem?
     
  3. abused1

    abused1 Member

    Joined:
    Jan 19, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    sneader what os is your server? we are all RH 9
     
  4. puzz1ed1

    puzz1ed1 Active Member

    Joined:
    Jan 31, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thurrock, UK
    aspell is running out of control on our RH9 box also, but is being stopped by PRM when it gets out of hand. Stops the server crashing, but need to find a better solution :)
     
  5. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Seeing the same issue - RH8
     
  6. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Yep, same here... actually Fedora Legacy.

    I opened a ticket with cPanel, after finding some stuff on the Internet.

    In part of my ticket, I wrote:

    > I found this one the web... Same problem: http://lists.gnu.org/archive/html/aspell-user/2003-02/msg00028.html
    >
    > Proposed solution: http://lists.gnu.org/archive/html/aspell-user/2003-02/msg00030.html

    cPanel replied to this part with:


    Since its a known bug with aspell go ahead and upgrade to aspell 0.50 like it recommends and then see if it resolves it.

    Horde's spell check is what uses it, just FYI. So i the upgrade doesn;t work it may need rebuilt into PHP:

    if /var/cpanel/usecpphp exists:
    /scripts/makecpphp
    if it does not then do:
    /scripts/easyapache option 7

    Let me know if that resolves it or not, thanks!
    --
    Daniel Muey
    cPanel Support Level II​


    I have not had time to put any further time into it. We've disabled it on our box for now.

    - Scott
     
  7. cretu

    cretu Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    208
    Likes Received:
    0
    Trophy Points:
    16
    Hi there,

    I have attempted to upgrade the ASpell by /scripts/perlinstaller aspell and recompiled PHP, however, this did not help and aspell process is contantly running at very high CPU usage.

    Any alternatives, suggestions?

    Cretu
     
  8. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    I had tested upgrading aspell. It works fine.
     
  9. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    silversurfer, can you detail what you did to upgrade/fix aspell?

    - Scott
     
  10. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    Sure. I assumed you are logged in as root on shell.

    1. In my server, I have the Redhat aspell RPMs. Therefore, I want to remove them. To remove them, I want to find out the packages names.

    rpm -qa | grep aspell

    2. In your box, this may defer. But on mine, I found this 3 packages.

    rpm -e aspell-0.33.7.1-25.3 aspell-devel-0.33.7.1-25.3 aspell-config-0.33.7.1-25.3

    3. Download the updated version and the dictionary files

    cd /usr/local/src
    wget ftp://ftp.gnu.org/gnu/aspell/aspell-0.60.2.tar.gz
    wget ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-6.0-0.tar.bz2

    4. Unzip the files

    tar -zvxf aspell-0.60.2.tar.gz
    tar -jxvf aspell6-en-6.0-0.tar.bz2

    5. Configuring and compiling

    cd aspell-0.60.2
    ./configure
    make
    make install

    cd ../aspell6-en-6.0-0
    ./configure
    make
    make install

    6. Add a sym link
    ln -s /usr/local/bin/aspell /usr/bin/aspell


    You can test it with:

    echo "<html><body>blah lindner" | /usr/bin/aspell -a -d american -H

    or

    echo "<html><body>blah lindner" | /usr/local/bin/aspell -a -d american -H

    You can also do the following to check version:

    root@ [/usr/local/src/aspell6-en-6.0-0]# aspell -v
    @(#) International Ispell Version 3.1.20 (but really Aspell 0.60.2)
     
    #10 silversurfer, Feb 26, 2005
    Last edited: Feb 26, 2005
  11. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    silversurfer, that was WAY beyond the call of duty to spell it out (pun intended) for me like that. I was able to successfully get aspell upgraded!

    My final problem (I hope) is being able to use aspell correctly. Maybe I'm just doing something stupid, but when I spell check an e-mail, it gives me suggestions, I choose one of the suggestions, click on the "change" radio button, then NEXT. And it thinks for a while, then comes back with the same errors... it doesn't change any of the words.

    EDIT: PROBLEM SOLVED!! I was using the 3rd party "proxy" software, which allows users to get to webmail without using port 2095 (so, they can get webmail via http://webmail.myhost.com for example). When I get to webmail via http://www.custdomain.com/webmail which is the normal way for people to get to webmail, then it works just fine!!!

    Thanks silversurfer -- I hope I can return some type of favor in the future!!

    - Scott
     
    #11 sneader, Feb 26, 2005
    Last edited: Feb 26, 2005
  12. ttremain

    ttremain Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    Also, before creating the symlink ln -s /usr/local/bin/aspell /usr/bin/aspell

    You should: rm -f /usr/bin/aspell

    I also decided to add:
    killall aspell

    to get rid of all rogue prodcesses that might still be running.
     
  13. ahbao

    ahbao Member

    Joined:
    Mar 4, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    same to my rhe3 box. it take up 1.2g of memory when I only have 2g

    aspell version

    root@server [~]# aspell -v
    @(#) International Ispell Version 3.1.20 (but really Aspell .33.7.1 alpha)

    I have disabled it
     
  14. scottabq

    scottabq Member

    Joined:
    Jul 28, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here - brand new rhe 3 cp box - International Ispell Version 3.1.20 (but really Aspell .33.7.1 alpha)

    Just run a spell check in horde and be ready to kill aspell. Thanks for the posts.
     
  15. panayot

    panayot Well-Known Member

    Joined:
    Nov 18, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    Thanks a lot silverserfer!

    All worked great on RHE

    The only change I had to make was to add --nodeps:

    rpm -e --nodeps aspell-0.33.7.1-25.3 aspell-devel-0.33.7.1-25.3 aspell-config-0.33.7.1-25.3

    because some squirrelmail rpms seemed to have dpendencies on the aspell rpms ( I do not see any spellchecking in squirrelmail, but anyway..)
     
  16. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    You can actually remove the squirrelmail rpms. Cpanel doesn't use it. So just remove it together with Aspell and you should be good to go.
     
  17. ProLamer

    ProLamer Active Member

    Joined:
    May 17, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    When i was trying to uninstall the aspell RPM, there got such error message:

    aspell is needed by (installed) xfig-3.2.3d-12

    how can i deal with this?

    thanks
     
  18. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    If you do not need that, add that package to the remove list when you do rpm -e
     
  19. ProLamer

    ProLamer Active Member

    Joined:
    May 17, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Thanks a lot
     
  20. mike25

    mike25 Well-Known Member

    Joined:
    Aug 29, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Raleigh NC, USA
    I have upgraded all my servers, but I am still having on server that will sometimes, about once every 2 weeks, have aspell lock up again. I believe I have the latest version :

    @(#) International Ispell Version 3.1.20 (but really Aspell 0.60.2)

    But I still continue to have this problem. I have chmod'd aspell so it will no longer run, does anyone know of any other fixes for this?
     
Loading...

Share This Page