ksihota

Registered
Oct 8, 2003
4
0
151
I want to upgrade Aspell from the current Aspell/Pspell combo to Aspell .6

How do I uninstall the current Aspell (I have not compiled Apache with Pspell) or do I have to?
Has anyone upgraded?
Does CPanel try and overwrite the installation with the older version?
Why is Cpanel still using the outdated version?

Thanks for any help.

KS
 

anaxamaxan

Registered
Oct 12, 2004
4
0
151
Updating Aspell

I have this issue as well. And, since the original poster got 0 responses, I am doubting this will get anywhere either. I would like to update my aspell install to the current (0.6.3) version, but cPanel will only install the ancient 0.33. Is there some reason not to do it the old fashioned way?
 

ksihota

Registered
Oct 8, 2003
4
0
151
Aspell upgrade??

Hi anaxamaxan,

This was quite a while ago and I can't remember exactly what I did but these are the steps I took (use at your own risk) I will check around for you and see if I can find the original post where I got the directions and post them or a link here if I can find it again. Aspell is working fine on my machine since I upgraded.

KS

rpm -qa | grep aspell
rpm -e aspell-0.33.7.1-25.3 aspell-devel-0.33.7.1-25.3 aspell-config-0.33.7.1-25.3 aspell-en-ca-0.33.7.1-25.3
rpm -e --nodeps aspell-0.33.7.1-25.3 aspell-devel-0.33.7.1-25.3 aspell-config-0.33.7.1-25.3 aspell-en-ca-0.33.7.1-25.3
cd /usr/local/src
wget ftp://ftp.gnu.org/gnu/aspell/aspell-0.60.2.tar.gz
wget ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-6.0-0.tar.bz2
tar -zvxf aspell-0.60.2.tar.gz
tar -jxvf aspell6-en-6.0-0.tar.bz2
cd aspell-0.60.2
./configure
make
make install
cd ../aspell6-en-6.0-0
./configure
make
make install
ln -s /usr/local/bin/aspell /usr/bin/aspell
echo "<html><body>blah lindner" | /usr/local/bin/aspell -a -d american -H
 

anaxamaxan

Registered
Oct 12, 2004
4
0
151
Thanks!

Yeehaw. Thank you so much KS for the instructions and the link. I wanted this to get SpellerPages running correctly for my FCKEditor install, and now it's working beautifully.