The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Assigned Nameserver Ips

Discussion in 'Bind / DNS / Nameserver Issues' started by user1101, Jul 12, 2006.

  1. user1101

    user1101 Registered

    Joined:
    Jul 11, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello -

    I have a new server with cPanel 4.

    Am in setup process and hbave a question regarding the setup.

    First, under basic set there are two button links for each of the Name Server Sections. It is unclear if activating these buttons is required after entering in the required hostname of the primary and secondary nameservers.

    so here what is the purpose of these links? Do you need to manually activate each one for "Assign IP Address" and "Add an A entry"?

    withbouth doing so when I go to Network Setup and list nameserver IP's there are no entries listed after the tool completes processing which typically takes several seconds.

    If the nameservers have already been assigned through basic, this eems redundant or is this for something else ie setting up the new server as its own dns?

    Also, when I make changes to the setup I get these errors:

    Bind reloading on serverName using rndc zone:
    Error reloading bind on light: rndc: error: /etc/rndc.key:2: expected string near ';'
    rndc: could not load rndc configuration


    when I try running fixrndc I get:


    Error reloading bind on light: rndc: error: /etc/rndc.key:2: expected string near ';'
    rndc: could not load rndc configuration


    the first chunk of named.conf :

    Code:
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { ""; };
    };
    
    //
    // named.conf for Red Hat caching-nameserver
    //
    
    options {
            directory "/var/named";
            dump-file "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
             // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    
    zone "." IN {
            type hint;
            file "/var/named/named.ca";
    };
    
    zone "localdomain" IN {
            type master;
            file "/var/named/localdomain.zone";
            allow-update { none; };
    };
    
    zone "localhost" IN {
            type master;
            file "/var/named/localhost.zone";
    rndc.key contains:

    Code:
    key "" {
            algorithm ;
            secret "";
    };
    thanks, any help is appreciated.
     
    #1 user1101, Jul 12, 2006
    Last edited: Jul 12, 2006
  2. hostmedic

    hostmedic Well-Known Member

    Joined:
    Apr 30, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Washington Court House, Ohio, United States
    cPanel Access Level:
    DataCenter Provider
    same here

    same here on a new system...
     
  3. user1101

    user1101 Registered

    Joined:
    Jul 11, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Fixed; See notes

    I opened a ticket after all my hair was gone and the prompt reply from my datacenter is as follows:

    Code:
    Unfortunately, these BIND errors are commonplace on newly installed cPanel servers. It was corrected with the following commands:
    
    /usr/sbin/rndc-confgen -a
    /scripts/fixrndc -fv
    I hope this helps anyone having the same issues.
     
Loading...

Share This Page