Attached Google DMARC reports sent as domain rejected

bloatedstoat

Well-Known Member
Jun 14, 2012
183
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
Hello,

Our server is rejecting DMARC report emails sent from Google. Rather than zip up the XML file like many other services they appear to be sending the report attached to the email as "google.com!ourdomain.com"

Our server has .com in the banned attachments list for good reason, as such the mail is being rejected where it sits in our mail delivery queue because the return address is noreply-dmarc-supportATgoogle.com.

I could of course remove .com from exim's mail filter but I'd rather not. Did a spot of research and this appears to be the only workaround I've come across thus far.

Anyone have an alternative solution?

Thanks.
 

RWH Tech

Well-Known Member
Oct 1, 2015
86
16
8
Brazil
cPanel Access Level
Root Administrator
I use this in a modified filter file( /etc/cpanel_exim_system_filter_fixed ) so it's not overwritten:

Code:
# DO NOT FILTER MESSAGES TO ABUSE OR POSTMASTER
if $h_to: contains "postmaster" or $h_to: contains "abuse"
then
        finish
endif
 
  • Like
Reactions: bloatedstoat

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

Internal case CPANEL-7667 is included with cPanel version 60 to fix this issue. Here's a description of the resolution from the case:

The Exim system filter for malicious file types could falsely flag unquoted names that contained a Windows extension somewhere in them. For example, "google.com.zip" would be flagged because it matched the pattern for ".com" (a DOS executable type). If the text is not in quotation marks, anchor it on whitespace, a semicolon, or a line break.

Information about the build tiers and release process is available at:

Product Versions and the Release Process - cPanel Knowledge Base - cPanel Documentation

Thank you.
 
  • Like
Reactions: RWH Tech