The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attempt to Deliver all messages in Queue doesnt work

Discussion in 'General Discussion' started by Snowman30, Apr 23, 2004.

  1. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    For some reason ive found the Attempt to Deliver all messages in Queue link in WHM's mail queue pages inst working anymore...

    on some servers it moves straight to complete as soon as you click on it, on others it just sits with a blank page and on others it says its doing it but nothing appears to be happening.

    Is there a way to force it to work or a way to fix it?
     
  2. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I seem to be having this same issue now. I have about 2.5k messages in the queue from a user that ran out of space. They have enough space now, but I don't what to deliver all those messages one at at time.... Has anyone found a fix for this? I'm running version 9.4.1-C53
     
  3. ttiger

    ttiger Member

    Joined:
    Sep 1, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. 1053 messages in the queue and can only deliver if I manually click on each one. Could someone please tell me how to get the "attempt to deliver all messages" function to work.
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    exim -qff

    the load on the server may shoot high; but this will flush the mail queue.
     
  5. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    The advice to use the command

    exim -qff

    is good, *BUT* the issue here is that

    WHM > Attempt to deliver all messages in Queue

    is not working properly. Period. If using the above WHM feature does not remove mail from the queue, but manually clicking on each one individually does, then again, this WHM feature is not working properly, and should be fixed.

    I've added Bug 3271 to bugzilla.cpanel.net.
     
    #5 spaceman, Sep 24, 2005
    Last edited: Sep 24, 2005
  6. alwaysweb

    alwaysweb Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas, TX
    cPanel Access Level:
    Root Administrator
    Spaceman, Please see:

    http://bugzilla.cpanel.net/show_bug.cgi?id=3271

    they are asking for more details about the bug to continue...

    Nearly a year after you entered this bug, I still see this problem on all of our cpanel servers. If you could reply to the question asked in bugzilla, maybe someone can look at this for us all :D
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you, by any chance, using MailScanner? If you are then it won't work as it uses a different queue and you'd need to:

    exim -qff -C /etc/exim_outgoing.conf

    Otherwise, ignore me ;)
     
  8. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    We're not using MailScanner at this time (thanks all the same for the suggestion). That said, I don't know if this problem still persists and can't test it right now because all the messages on the queues for our servers are outbound, and I need a fair few inbound messages to be able test properly.
     
  9. maverick23

    maverick23 Well-Known Member

    Joined:
    Feb 23, 2005
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    DataCenter Provider
    try running /usr/sbin/exim -bp |awk '{print $3}' | xargs -n 1 -P 40 /usr/sbin/exim -v -M from root prompt this will deliver all the mails which can be delivered.. :)
     
  10. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    I just updated this bug. It's still very much alive and well. "Attempt to deliver all messages in queue" is absolutely *not* able to deliver messages that can get delivered successfully if I manually click "Deliver now" against them - which is very time consuming!
     
  11. brendanrtg

    brendanrtg Well-Known Member

    Joined:
    Oct 4, 2006
    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    16
    Setting up a cron to do it DAILY may do the trick?

    /usr/sbin/exim -bp |awk '{print $3}' | xargs -n 1 -P 40 /usr/sbin/exim -v -M

    Anyone?
     
  12. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Which command is recommended and whats the difference?

    /usr/sbin/exim -bp |awk '{print $3}' | xargs -n 1 -P 40 /usr/sbin/exim -v -M

    exim -qff
     
  13. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    /usr/sbin/exim -bp |awk '{print $3}' | xargs -n 1 -P 40 /usr/sbin/exim -v -M

    This works better i bealive....
     
  14. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    How would I attempt to deliver email in the queue specifically for one user, e.g. user@domain.com?
     
  15. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
  16. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That would do it :)

    From shell you'd use:

    exim -v -Rff userdomain.com
     
Loading...

Share This Page