The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Attempting to drop privileges to root..." - Unable to login from WHM to cPanel

Discussion in 'General Discussion' started by MaxTM, Apr 18, 2016.

  1. MaxTM

    MaxTM Registered

    Joined:
    Apr 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ukaine
    cPanel Access Level:
    Root Administrator
    Hi, cPanel Team.

    My problem was discussed before here. But there thread is died and no any answers with solution.

    The problem in login from WHM to any user's cPanel account. When I click on cPanel icon in "List Accounts" page, new page opens but there goes next error:

    _______________________________________________________
    Internal Server Error
    500

    exit level [die] [pid=7313] (Attempting to drop privileges to root.)

    cpsrvd/11.56.0.3 Server at my.server.net
    _______________________________________________________

    But, strange thing is: this error appear only in my Safari browser. :)
    And another strange thing: this error not appears if I'm run new private windows in Safari.

    This error not appear in Firefox in normal and private modes. In another browsers I didn't check.

    The logs /usr/local/cpanel/logs/error_log:

    [2016-04-18 17:10:58 +0100] die [cpsrvd] Attempting to drop privileges to root. at /usr/local/cpanel/Cpanel/AccessIds/ReducedPrivileges.pm line 141.
    Cpanel::AccessIds::ReducedPrivileges::_prevent_dropping_to_root(0, 0) called at /usr/local/cpanel/Cpanel/AccessIds/ReducedPrivileges.pm line 77
    Cpanel::AccessIds::ReducedPrivileges::call_as_user(CODE(0xf384d8), "root") called at /usr/local/cpanel/Cpanel/Server.pm line 1310
    Cpanel::Server::update_lastlogin(Cpanel::Server=HASH(0x27e2e70), "root") called at /usr/local/cpanel/Cpanel/Server.pm line 1289
    Cpanel::Server::newsession(Cpanel::Server=HASH(0x27e2e70), __CPANEL_HIDDEN__, 1, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, ...) called at cpsrvd.pl line 3803
    cpanel::cpsrvd::handle_auth_transfer("") called at cpsrvd.pl line 1325
    cpanel::cpsrvd::handle_one_connection() called at cpsrvd.pl line 784
    cpanel::cpsrvd::script() called at cpsrvd.pl line 334
    [2016-04-18 17:10:58 +0100] info [cpsrvd] Internal Server Error: "GET /xfercpanel HTTP/1.1" 500 exit level [die] [pid=7313] (Attempting to drop privileges to root.)


    What I have tried to do to resolve this issue:

    1. Tried to whole Safari clearing (cache, cookie, also removed all extensions).
    2. Tried to different Easyapache configurations (with or without mod_security, mod_ruid2).
    3. The certain option "Accounts that can access a cPanel user account" in "Tweak settings" set to "Root, Account-Owner, and cPanel User default"
    4. Firewall CSF uninstalled.
    5. ...

    I know that the problem is in my WHM setup, because with the same Safari browser I try to login to user's cPanel accounts on another server and all fine. But, I can't resolve, which settings I made wrong. And no success with Google search...

    Is anybody can help me?

    I'm ready to provide any additional information.

    Current used cPanel/WHM version: 56.0 build 3 - CURRENT branch
    RELEASE branch also was tried.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify if multiple UID zero users exist on this system? You can check with a command such as:

    Code:
    grep 0:0 /etc/passwd
    Thank you.
     
  3. MaxTM

    MaxTM Registered

    Joined:
    Apr 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ukaine
    cPanel Access Level:
    Root Administrator
    Hi, Michael!

    Noup. There user root only.

    grep 0:0 /etc/passwd
    root:x:0:0:root:/root:/bin/bash
     
  4. MaxTM

    MaxTM Registered

    Joined:
    Apr 18, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ukaine
    cPanel Access Level:
    Root Administrator
    Hello, Michael!
    Have you any other ideas?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page