Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attempting To Grant an existing database user access to a specific database

Discussion in 'Database Discussion' started by linux1212, Feb 19, 2018.

  1. linux1212

    linux1212 Registered

    Joined:
    Jan 17, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    San Antonio, Texas
    cPanel Access Level:
    Root Administrator
    Attempting To:

    Grant an existing database user access to a specific database



    Problem/Error:

    The system received an error from the “MySQL” database “mysql”: ER_PASSWORD_NO_MATCH (Can't find any matching row in the user table)



    Description:

    cPanel/WHM is adding new entries to the “mysql” table as follows:


    mysql> select host, user from user where user = 'm2contra_txllc';

    +----------------------------------+----------------+

    | host | user |

    +----------------------------------+----------------+

    | IP | m2contra_txllc |

    | localhost | m2contra_txllc |

    | hostname| m2contra_txllc |

    +----------------------------------+----------------+

    3 rows in set (0.00 sec)


    These entries should only contain “localhost” -- but there’s no way to remove the additional “remote access hosts” from the system.


    Here’s the documentation for allowing access from external hosts:

    Remote MySQL - Version 68 Documentation - cPanel Documentation


    I can’t find where it’s getting the IP / hostname
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,245
    Likes Received:
    1,759
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Check to see if the skip-name-resolve option is enabled in your /etc/my.cnf file with the following command:

    Code:
    grep skip-name-resolve /etc/my.cnf
    This option is unsupported, and can lead to the error message you have provided.

    Thank you.
     
Loading...

Share This Page