The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attention! SSH is now enable in each package. Even if you it did not enable !!!

Discussion in 'General Discussion' started by avik, May 31, 2003.

  1. avik

    avik Member

    Joined:
    May 31, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Attention! SSH is now enabled in each package. Even if you it did not enabled !!!

    I have:
    WHM 6.4.2 Cpanel 6.4.2-R47 RedHat 7.3
    In each package SSH is not enabled.
    But after creation of the host-plan SSH is enabled.

    I tried it on several servers.
    Friend also has this problem.


    CPanel support, please fix it ASAP!!!

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
    #1 avik, May 31, 2003
    Last edited: May 31, 2003
  2. Beowulf

    Beowulf Active Member

    Joined:
    Feb 16, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I have this same problem and going through over 400 accounts is not a fun job removing access.

    cPanel.net Support Ticket Number: 15011
     
    #2 Beowulf, Jun 1, 2003
    Last edited: Jun 2, 2003
  3. princo

    princo Well-Known Member

    Joined:
    Feb 22, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Europe
    Me too

    cPanel.net Support Ticket Number:
     
  4. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Me too facing the same problem. I have got 1000's of accounts on my server's.

    :mad:

    cPanel.net Support Ticket Number:
     
  5. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I see four people mentioning about this problem and yet, not one has listed a Ticket number?

    BTW, I only use the Edge version (currently #46) and a quick test showed I do not have this problem.

    cPanel.net Support Ticket Number:
     
  6. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    I do not have this problem either... And I do use the latest edge for the moment.

    cPanel.net Support Ticket Number:
     
  7. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Im on Cpanel 6.4.2-S48
    RedHat 7.3

    And the problem continue.

    Any solution for this ?

    Thanks in advance

    cPanel.net Support Ticket Number:
     
  8. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Have people tried upgrading to stable_51 or release_50 to see weather the problem is resolved?

    cPanel.net Support Ticket Number:
     
  9. TioChaharbaghi

    Joined:
    Apr 17, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Do you see it enabled under "Modifying an account"?

    Where exactly do you see it re enabled?

    Because when i go to modify an account its still disabled

    6.4.2 R50

    cPanel.net Support Ticket Number:
     
  10. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    >>Do you see it enabled under "Modifying an account"?

    yes

    Where exactly do you see it re enabled?

    In "modify an acocunt" and in the "manage shell" option

    Because when i go to modify an account its still disabled

    6.4.2 R50

    I will try upgrade to stable 51 to see if something change.

    Thank you !

    cPanel.net Support Ticket Number:
     
  11. infinityws

    infinityws Well-Known Member

    Joined:
    Feb 20, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    I just checked my box and running S48 and all accounts still have NO shell access. So I have no idea why you guys are getting this issue.

    cPanel.net Support Ticket Number:
     
  12. Darren

    Darren Well-Known Member
    Staff Member

    Joined:
    Dec 26, 2001
    Messages:
    1,957
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Houston, TX
    a fix

    Hello,

    For those of you having this problem, try running the following perl sript to see if it fixes it.
    I've only been able to test it on one server so far, so following the directions for backing up the packages first would be a good idea :)

    http://faq.cpanel.net/pkgfix.txt

    Thanks,
    Darren

    cPanel.net Support Ticket Number:
     
  13. WeMasterz5

    WeMasterz5 Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Miami
    WHM 6.4.2 Cpanel 6.4.2-S48 RedHat 8.0 and I dont see this :cool:

    cPanel.net Support Ticket Number:
     
  14. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Whoa! I'm using Edge 51, and it's happening to me! Thanks for the warning, avik. This definitely needs to be fixed.

    cPanel.net Support Ticket Number: 15072

    I'll try those fixes and get back.
     
    #14 casey, Jun 2, 2003
    Last edited: Jun 2, 2003
  15. Darren

    Darren Well-Known Member
    Staff Member

    Joined:
    Dec 26, 2001
    Messages:
    1,957
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Houston, TX
    Hello,

    It might also work to edit the packages having this problem in WHM, you don't need to change anything, just save (edit button) them each and it should save it with the needed information in the package config file if you do not want to run the perl script to fix it.

    Thanks,
    Darren

    cPanel.net Support Ticket Number:
     
  16. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Okay, I did that, but it was not very convenient. I didn't realize it was going to remove the extra features some of my clients had paid for. I had to go in and change individual accounts after that. We'll see if it worked...

    cPanel.net Support Ticket Number:
     
  17. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Well....we updated to the S51 and prblem continue, we need a fix for this as soon as possible please.


    Thanks again!

    cPanel.net Support Ticket Number:
     
  18. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    Then put in a ticket with cpanel, and then start adding the ticket number to you posts here on that subject.

    cPanel.net Support Ticket Number:
     
  19. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Further testing has shown there is some validity to the claim made, for this thread topic.

    After doing more testing on my own, I have determined that, on or about Cpanel 6.4.2 v12 and up (probably with any type used, S/R/E), NEW ACCOUNTS ONLY, are granted SSH access. Previously setup accounts "were not" affected -- at least, not with mine; I only use Edge so YMMV.

    It is recommended that everyone, regardless of what version or type of WHM/Cpanel being used, check & verify for SSH access to accounts that should not have it.

    WHM > Account Functions > Manage Shell Access

    Dis-abling it from that area of WHM is probably the easiest way -- although you still have to do them one at a time.


    This thread was specifically mentioned in the Ticket, so a post or a fix from DarkOrb, should be forthcoming -- hopefully real soon. ;)

    cPanel.net Support Ticket Number: 15135
     
    #19 Website Rob, Jun 3, 2003
    Last edited: Jun 3, 2003
  20. Darren

    Darren Well-Known Member
    Staff Member

    Joined:
    Dec 26, 2001
    Messages:
    1,957
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Houston, TX
    *** THIS IS THE FIX SCRIPT ***

    For those of you missed the first post I made about it.

    ***HERE IS THE FIX FOR THE PROBLEM CONCERNING SSH BEING ENABLED FOR EACH NEW ACCOUNT***

    http://faq.cpanel.net/pkgfix.txt

    Thanks,
    Darren

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page