The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

authdaemond: Failed to getpwnam for user

Discussion in 'General Discussion' started by rajinnasik, Jun 9, 2012.

  1. rajinnasik

    rajinnasik Member

    Joined:
    Nov 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I can not send emails from email account test1@domain.com using Thunderbird or Outlook. Webmail works though.

    ThunderBird shows error message:

    -----
    Sending of message failed.
    The message could not be sent using SMTP server mail.domain.com for an unknown reason. Please verify that your SMTP server settings are correct and try again, or contact your network administrator.
    ----

    The maillog shows the following logs.

    ------
    Jun 9 05:43:49 atlas2 pop3d: Connection, ip=[::ffff:xx.xx.xx.xx]
    Jun 9 05:43:49 atlas2 authdaemond: Failed to getpwnam for user test1
    Jun 9 05:43:49 atlas2 pop3d: LOGIN FAILED, user=test1, ip=[::ffff:xx.xx.xx.xx]
    ------

    Exim_mainlog shows:

    --------
    2012-06-09 06:35:30 courier_plain authenticator failed for hostname [xx.xx.xx.xx]:65520: 535 Incorrect authentication data (set_id=test1)
    2012-06-09 06:35:30 courier_login authenticator failed for hostname [xx.xx.xx.xx]:65520: 535 Incorrect authentication data (set_id=test1)
    --------

    I have updated cpanel to release version, ran eximup, tried changing from courier to dovecot mail servers and vice versa. Reinstalled the perl as well.

    Any more suggestions? Please help.
     
    #1 rajinnasik, Jun 9, 2012
    Last edited: Jun 9, 2012
  2. MilesWeb

    MilesWeb Well-Known Member
    PartnerNOC

    Joined:
    May 23, 2012
    Messages:
    174
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Did you check ownership on etc directory under /home/cPanel-username ? Ownership should be set to cPaneluser.mail Try using the same login details using webmail. See if it works.
     
  3. rajinnasik

    rajinnasik Member

    Joined:
    Nov 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for replying. Yes checked. /home/user/etc has ownership user:mail
    I assure that there is no issue with permissions and ownership for the email accounts.
    This is server wide issue. Not for particular domain/email.

    Any more suggestions? Please help.
     
  4. tc0

    tc0 Member

    Joined:
    Jul 20, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1


    I get these messages (or similar) when an IP of one of my customers has suddenly appeared on the cphulkd-brutes list. You can use WHM:phpmyadmin to search db cphulkd's tables for the IP address and delete the entries in brutes.

    GL & 73
     
Loading...

Share This Page