The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Authenticate smtp user

Discussion in 'E-mail Discussions' started by mfragoso, Oct 28, 2003.

  1. mfragoso

    mfragoso Active Member

    Joined:
    Oct 17, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Mexico City
    cPanel Access Level:
    Root Administrator
    My cpanel is just installed, but I would like to set authentication while sending mail. (My server requires authentication checkbox in outlook)

    How do I modify the exim setting to make this happen?

    Thanks
     
  2. webline

    webline Member

    Joined:
    Nov 6, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Singapore
    i would like to know the answer to the above question too. anyone out there could offer a helping hand here?
     
  3. dlemkin

    dlemkin Member

    Joined:
    Apr 6, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Question still stands...

    Yet another looking for this information.

    On VPS systems, I was told you can not enable the SMTP Tweak or none of the smtp functions will work.

    Anyone know how to secure outgoing email on VPS servers to prevent remote spammers from utilizing our servers.
     
  4. myrem

    myrem Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Re: Question still stands...

    cpanel's exim configuration blocks relaying so only authenticated remote users can send outbound email through your server.

    The SMTP Tweak is merely for stopping scripts on your server from directly sending outbound SMTP mail which bypass Exim. Has nothing to do with remote SMTP users.
     
  5. dlemkin

    dlemkin Member

    Joined:
    Apr 6, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Cool thanks.
     
  6. tawfiq

    tawfiq Active Member

    Joined:
    Mar 13, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    i would also like to know how to enable username/password smtp authentication please!!!!!!
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It should be anabled already. Exim under cPanel comes configured with 2 authentication methods:

    1. POP before SMTP (must send within 30 minutes of POPing)
    2. SMTP AUTH
     
  8. everette

    everette Registered

    Joined:
    May 25, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Re: Re: Question still stands...

    Not sure what you mean here.

    I'm on VPS, If I enable the SMTP Tweak, I can send no outgoing email to a remote server. Period. I can send all the email I want to a local email address. But anything not local is refused connections.
     
  9. alex042

    alex042 Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Try checking your pop mail for the account you want to send mail before you send mail.
     
  10. everette

    everette Registered

    Joined:
    May 25, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    VPS SMTP Tweak

    It's not a problem of connecting to the SMTP server. The mail stays in the exim queue and never gets transported to its destination.
     
  11. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    "SMTP AUTH" work only with the master login ( cpanel login ).


    it don't work with pop3 login.
     
  12. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    "SMTP AUTH" work only with the master login ( cpanel login ).


    it don't work with pop3 login.
     
  13. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    See your other threads...
    Yes, pop3 logins DO work with SMTP auth.
     
  14. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Sorry to distrub all you guys...again

    It's my fault............




    The system look like support both PLAIN and LOGIN which are standard auth.
    Now I test with outlook express ( microsoft use AUTH LOGIN )
    Outlook Express 5.50.4942.400


    I still get error message.

    SMTP: 09:52:38 [rx] 535 Incorrect authentication data


    I am sure that the EXIM should work with AUTH LOGIN with POP3 login 100%.
    Then I create new POP3 login and test it. Wow! it works very well.
    I think the problem come from a corrupt password data file.
    So I change my password of the trouble login. Wow! it works! right now.



    SMTP: 10:23:39 [rx] 220-maldives.micfo.com ESMTP Exim 4.44 #1 Mon, 07 Feb 2005 21:23:36 -0600
    SMTP: 10:23:39 [rx] 220-We do not authorize the use of this system to transport unsolicited,
    SMTP: 10:23:39 [rx] 220 and/or bulk e-mail.
    SMTP: 10:23:39 [tx] EHLO TONG
    SMTP: 10:23:39 [rx] 250-maldives.micfo.com Hello TO [203.150.111.41]
    SMTP: 10:23:39 [rx] 250-SIZE 52428800
    SMTP: 10:23:39 [rx] 250-PIPELINING
    SMTP: 10:23:39 [rx] 250-AUTH PLAIN LOGIN
    SMTP: 10:23:39 [rx] 250-STARTTLS
    SMTP: 10:23:39 [rx] 250 HELP
    SMTP: 10:23:39 [tx] AUTH LOGIN
    SMTP: 10:23:40 [rx] 334 VXNlcm5hbWU6
    SMTP: 10:23:40 [tx] dG9uZ0B0YW90b29uLmNvbQ==
    SMTP: 10:23:43 [rx] 334 UGFzc3dvcmQ6
    SMTP: 10:23:43 [tx] QVlDNDlLOEI=
    SMTP: 10:23:45 [rx] 235 Authentication succeeded
    SMTP: 10:23:45 [tx] MAIL FROM: <to@toto.com>
    SMTP: 10:23:46 [rx] 250 OK
    SMTP: 10:23:46 [tx] RCPT TO: <test@mail.com>
    SMTP: 10:23:51 [rx] 250 Accepted
    SMTP: 10:23:51 [tx] DATA
    SMTP: 10:23:56 [rx] 354 Enter message, ending with "." on a line by itself
    SMTP: 10:23:56 [tx]
    .
    SMTP: 10:23:59 [rx] 250 OK id=1CyLyg-0007T0-Fl
    SMTP: 10:23:59 [tx] QUIT
    SMTP: 10:23:59 [rx] 221 maldives.micfo.com closing connection
     
    #14 taotoon, Feb 7, 2005
    Last edited: Jun 26, 2009
  15. Alexandre

    Alexandre Member
    PartnerNOC

    Joined:
    Jan 21, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    U.S.A.
    The same problem.


    2006-02-01 22:43:27 fixed_plain authenticator failed for (support-hostpro.it.local) [82.207.71.83]: 535 Incorrect authenticati
    on data (set_id=test@navsi100.com)
    2006-02-01 22:43:27 H=as-71.ar43.vc.ukrtel.net (support-hostpro.it.local) [82.207.71.83] F=<test@navsi100.com> rejected RCPT <
    dim_s@hostony.com>: as-71.ar43.vc.ukrtel.net (support-hostpro.it.local) [82.207.71.83] is currently not permitted to relay thr
    ough this server. Perhaps you have not logged into the pop/imap server in the last 30 minutes or do not have SMTP Authenticati
    on turned on in your email client.

    Nothing helped.


    P.S. SMTP authentication is enabled.
     
  16. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you checked that syslogd is working correctly and the pop/imap connections are logging in /var/log/maillog? If not, restart the syslog service.
     
Loading...

Share This Page