The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Auto-detected character encoding

Discussion in 'General Discussion' started by A.S., Dec 4, 2008.

  1. A.S.

    A.S. Registered

    Joined:
    Dec 4, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Finland
    I'm using cPanel Version 11.23.6-STABLE.

    You know this problem, don't you?

    Every time I'm opening a file with Code Editor in the Legacy File manager, I have to choose on the top ('Please select the character encoding to open this file with') from the dropdown menu the character encoding, because I'm using iso-8859-1 and the preselection in the dropdown menu is something else.

    cPanel:
    "We have attempted to auto-detect the encoding of this file. However, this is not a foolproof process since some files will display properly with multiple different encodings. You should select the encoding that this file was originally created with. It is very important that you select the proper encoding; saving your file with the wrong encoding may result in the corruption of your text."

    And yes, it will corrupt the file.

    What an idea is this??!! Can you imagine how irritating it is and how much time it takes to choose every time the character encoding when opening a file!!! What an earth you were thinking, cPanel developers???

    I have the code "meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" in all my files, so the auto-detected encoding is not working.

    The previous cPanel version worked with no problem at all in this issue!!! Please, do something.
     
    #1 A.S., Dec 4, 2008
    Last edited: Dec 4, 2008
  2. escapevelocity

    Joined:
    Dec 7, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    That was annoying enough, but even worse: NOW I can't use contractions anymore, it automatically turns them into this: can't won't don't

    Please tell me how to make this stop! I've tried a dozen different options and it does it in all of them!
     
Loading...

Share This Page