The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Auto SSL Failed Domain Control Validation

Discussion in 'Security' started by batgranny, Jan 26, 2017.

Tags:
  1. batgranny

    batgranny Member

    Joined:
    Aug 3, 2015
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Ireland
    cPanel Access Level:
    Root Administrator
    Hi,

    I've just started to use Auto SSL and Let's Encrypt and have found it to fail validation for a lot of our domains:

    Code:
    ARN The domain “domain.com” has failed domain control validation (The system queried for a temporary file at “<a href="[URL='http://domain.com/714829.BIN_AUTOSSL_CHECK_PL__.EH0ccfeMXVV_02jq.tmp']http://domain.com/714829.BIN_AUTOSSL_CHECK_PL__.EH0ccfeMXVV_02jq.tmp[/URL]">[URL]http://domain.com/714829.BIN_AUTOSSL_CHECK_PL__.EH0ccfeMXVV_02jq.tmp[/URL]</a>”, but the web server responded with the following error: 404 (Not Found). A <abbr title="Domain Name System">DNS</abbr> or web server misconfiguration may exist.). at bin/autossl_check.pl line 449.
    I have a sneaking suspicion that this may be because we edit the web root to be a folder in /home/[user] other than public_html. Is this likely? If not what troubleshooting can I do to resolve this?
     
    #1 batgranny, Jan 26, 2017
    Last edited by a moderator: Jan 26, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,094
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look and see why the validation is failing? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. batgranny

    batgranny Member

    Joined:
    Aug 3, 2015
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Ireland
    cPanel Access Level:
    Root Administrator
    I've opened ticket number 8176885
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,094
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, it looks like this was the result of an unsupported custom document root configuration.

    Thank you.
     
  5. UmbrellaIT

    UmbrellaIT Registered

    Joined:
    Feb 10, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Los Angeles
    cPanel Access Level:
    Root Administrator
    Yes, AutoSSL is broken after last update (WHM 62.0 (build 10), it looks like the script is checking a different URL than before.
    it used to check /.well-known, now it's checking random string(file) ?, when did that change took place ?

    Code:
    href="https://www.example.com/UR6Q8141PNK...V1542XHQ2ZVL0QT6CEL2FHJIUQMKIBJ1G02FR7G5TQBGS">https://www.example.com/UR6QS8141PK...V1542XHQ2ZVL0QT6CEL2FJIUQMKIBJ1G02FR7G5STQBGS</a>”, which was redirected from “<a href="http://example.com/URQS8141PNKQ5SKP...1542XHQ2ZVL0QT6CEL2FHJIUQMKIBJ1G02FR7G5STQBGS">http://example.com/UR6QS8141PNKQ5SK...V1542XHQ2ZVL0QT6CEL2FHJIUQMIBJ1G02FR7G5STQBGS</a>”. The web server responded with the following error: 404 (Not Found). A <abbr title="Domain Name System">DNS</abbr> or web server misconfiguration may exist. at bin/autossl_check.pl line 562.
    12:20:22 AM WARN The domain “www.example.com” failed domain control validation: The system queried for a temporary file at “<a
    
    can anyone help ?
     
    #5 UmbrellaIT, Feb 10, 2017
    Last edited by a moderator: Feb 10, 2017
  6. UmbrellaIT

    UmbrellaIT Registered

    Joined:
    Feb 10, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Los Angeles
    cPanel Access Level:
    Root Administrator
    we were able to fix this by running
    Code:
    yum update cpanel-letsencrypt
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,620
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for updating the thread. :)
     
Loading...

Share This Page