Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Auto SSL fails to install certificate

Discussion in 'Security' started by nedimhx, Mar 13, 2017.

Tags:
  1. nedimhx

    nedimhx Registered

    Joined:
    Mar 13, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bosnia
    cPanel Access Level:
    Root Administrator
    Hello,

    I have about 10 websites and everyone is fine with auto ssl certeficates but one wich is transfered from another server, has problems with ssl from the beggining.

    After I try multiple solutions and finali when I delete everythin from ssl, cetrs, keys... folders
    I got this error when I try to install ssl again.
    The certificate information could not be retrieved because of an error: No certificate with ID “domain_name_com_b817d_bcb85_1520985153_76f9a476i63ezhb67b1546856a2feb6” exists.

    I'm using cpanel auto ssl, becouse I was blockd this domain on lelt's encrypt becouse of multiple ssl installs.

    How can I fix this error and finally install ssl cert to this domain ?

    Regards
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look and determine why AutoSSL isn't issuing the certificate? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. nedimhx

    nedimhx Registered

    Joined:
    Mar 13, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bosnia
    cPanel Access Level:
    Root Administrator
    License is ordered trough your partner, is that mean I can't ask help from you ?
     
  4. nedimhx

    nedimhx Registered

    Joined:
    Mar 13, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bosnia
    cPanel Access Level:
    Root Administrator
    Hello again,

    I have opened support ticket.
    Support Request ID is: 8303183
     
  5. nedimhx

    nedimhx Registered

    Joined:
    Mar 13, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bosnia
    cPanel Access Level:
    Root Administrator
    Solved following this steps from
    SOLVED - Can't receive mail


    The problem is fixed!

    /etc/userdomains shows mydomain.com was owned by the user nobody.

    Running:
    Code:
    root@franklin:/home # /scripts/whoowns mydomain.com
    nobody

    root@franklin:/home # mv -v /etc/userdomains /etc/userdomains.BAK
    root@franklin:/home # /scripts/updateuserdomains
    root@franklin:/home # /scripts/whoowns mydomain.com
    myusername

    So now I can recieve mails.


    Regarding AutoSSL cPanel stuff has solve this issue.

    Thank you very much cPanel :)
    Regards
     
    Infopro likes this.
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,747
    Likes Received:
    312
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for updating your thread.
     
Loading...

Share This Page