AutoConfig/AutoDiscover default to server hostname

wintech2003

Well-Known Member
PartnerNOC
Sep 15, 2010
103
28
78
Greece
cPanel Access Level
DataCenter Provider
Hello,

I believe this started with v60 or v62 (and enabling AutoSSL) and now mail clients will try to autoconfigure with "domain.com" instead of "hostname.server.com" even though "Host to publish in the SRV records for Outlook autodiscover support." is set to the server's hostname.

This is a problem when a client is for example behind CloudFlare, and as a result "domain.com" points to CloudFlare IPs instead of the actual server IP.

Is there a way to globally set the autodiscovery hostname to the server's hostname, and force it regardless of whether AutoSSL or Mail SNI is enabled?

Best regards,
George
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look at an affected domain name? You can post the ticket number here so we can update this thread with the outcome.

Thank you.