The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

autoconfig autodiscover port number

Discussion in 'E-mail Discussions' started by infomaniac50, Nov 4, 2015.

  1. infomaniac50

    infomaniac50 Member

    Joined:
    Jan 26, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Just outside of the singularity
    cPanel Access Level:
    Root Administrator
    Is there a way to change the default SMTP port number for autoconfig and autodiscover requests? Currently it sends 465 but I need it to send 587.

    I can't find any documentation on the cgi scripts themselves. Is the source code for these scripts located somewhere on the server, github or simply proprietary?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you changed the port number here?
    WHM »Service Configuration »Service Manager, Exim Mail Server (on another port)
     
  3. infomaniac50

    infomaniac50 Member

    Joined:
    Jan 26, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Just outside of the singularity
    cPanel Access Level:
    Root Administrator
    I changed the port number just now with no effect. I checked the enabled box but not the monitor. I set the field to 587 only. I did not add any other ports separated by commas.

    Sending a POST request with XML data is what I used to test it.
    Code:
    https://<!-- Host Address -->/autodiscover/autodiscover.xml
    
    Code:
    <?xml version="1.0" encoding="utf-8" ?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
        <Request>
            <EMailAddress><!-- Email Address --></EMailAddress>
            <AcceptableResponseSchema>http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a</AcceptableResponseSchema>
        </Request>
    </Autodiscover>
    
    I got this response.
    Code:
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
        <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
            <User>
                <DisplayName><!-- Email Address --></DisplayName>
            </User>
            <Account>
                <AccountType>email</AccountType>
                <Action>settings</Action>
                <Protocol>
                    <Type>IMAP</Type>
                    <Server><!-- Host Address --></Server>
                    <Port>993</Port>
                    <DomainRequired>off</DomainRequired>
                    <SPA>off</SPA>
                    <SSL>on</SSL>
                    <AuthRequired>on</AuthRequired>
                    <LoginName><!-- Email Address --></LoginName>
                </Protocol>
                <Protocol>
                    <Type>SMTP</Type>
                    <Server><!-- Email Address --></Server>
                    <Port>465</Port>
                    <DomainRequired>off</DomainRequired>
                    <SPA>off</SPA>
                    <SSL>on</SSL>
                    <AuthRequired>on</AuthRequired>
                    <LoginName><!-- Email Address --></LoginName>
                </Protocol>
            </Account>
        </Response>
    </Autodiscover>
    
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Did you open said port in your firewall as well?
     
  5. infomaniac50

    infomaniac50 Member

    Joined:
    Jan 26, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Just outside of the singularity
    cPanel Access Level:
    Root Administrator
    Yes. We don't use port 465 and 587 has been in use for some time now. As part of a PCI compliance process we disabled TLS on connect by setting it to port 466 in Exim's advanced configuration.

    The standard port number for submission is 587 and 465 has been deprecated for quite a while now.

    tools.ietf.org/html/rfc6409

    tools.ietf.org/html/rfc2487

    en.wikipedia.org/wiki/Simple_Mail_Transfer_Protocol#Ports
     
    #5 infomaniac50, Nov 5, 2015
    Last edited by a moderator: Nov 5, 2015
  6. infomaniac50

    infomaniac50 Member

    Joined:
    Jan 26, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Just outside of the singularity
    cPanel Access Level:
    Root Administrator
    Have you determined anything in regards to this issue?
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please feel free to open a ticket directly to cPanel Technical Support instead of waiting on a reply to this thread.
     
  8. RWH Tech

    RWH Tech Well-Known Member

    Joined:
    Oct 1, 2015
    Messages:
    74
    Likes Received:
    11
    Trophy Points:
    8
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Have you opened the ticket and obtained a resolution?
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, the user was advised that this feature does not currently offer the ability to implement a custom port number. The advice provided was to add feedback and vote for the following feature request that seeks out the ability to customize this information:

    Custom autoconfig.domain.com

    Thank you.
     
Loading...

Share This Page