The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Autodiscover - Outlook and iPhones

Discussion in 'E-mail Discussions' started by WebJIVE, Feb 26, 2015.

  1. WebJIVE

    WebJIVE Well-Known Member

    Joined:
    Sep 30, 2007
    Messages:
    53
    Likes Received:
    3
    Trophy Points:
    8
    We just ran into a big issue with autodiscover for Outlook and iPhones in the lastest 11.48, and submitting a support ticket has yielded no solution....

    Here's the challenge.. There's no way to have the proxy turned on, and on a per domain basis - disable it.

    Why would you want to do this? Because remote Outlook clients look to the FQDN for the autodiscover and when you have a remote Exchange server, guess what, the autodiscover tries to use the cPanel server XML instead of the remote Exchange server XML even when you have the DNS set to remote mail.

    As for iPhones, we're STUCK with the same problem we've been asking cPanel to fix for 2 years, get iPhone autodiscover working. This was also in my latest ticket where we have a client trying to setup iPhones and guess what, autodiscover isn't working for iPhones still. This shouldn't be this hard to get iPhone autodiscover/setup working correctly! The support agent blames it on iPhones...

    Anyone have any guidance on this?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    Any followup with this issue? I've setup Autodiscovery and it works fine using Thunderbird 31.6.0

    Using https://testconnectivity.microsoft.com and testing multiple domains passes all tests minus windows root cert.

    Using Exchange as a configuration option on iOS 8.3 and on Mac Mail 8.2 running on Yosemite does no auto configure server settings.

    On iOS 8.3 it just fails says it cannot configure the account, on Mail 8.2 it timeout and then asks for the server. When i enter the server, it says it could not communicate.

    I have the default A records, and SRV based on a domain with a valid SSL.

    Using the MS tool, i noticed that it failed the first two steps.

    Code:
    Attempting to test potential Autodiscover URL h ttps://clientdomain.tld:443/Autodiscover/Autodiscover.xml
    FAILED (normal, no SSL for that domain but gives mismatch due to main server not being the same hostname)
    
    Attempting to test potential Autodiscover URL h ttps://autodiscover.clientdomain:443/Autodiscover/Autodiscover.xml
    FAILED (tested using A record, pointing to client domain main ip, and cname to host with SSL and mail server with ssl, no results same issue. SSL mismatch error)
    
    Attempting to contact the Autodiscover service using the HTTP redirect method.
    The Autodiscover service was successfully contacted using the HTTP redirect method.
    
    The Microsoft Connectivity Analyzer is checking the host autodiscover.clientdomain.tld for an HTTP redirect to the Autodiscover service.
    
    The redirect (HTTP 301/302) response was received successfully.
    Redirect URL: h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml
    HTTP Response Headers:
    Keep-Alive: timeout=5, max=100
    Connection: Keep-Alive
    Content-Length: 0
    Content-Type: application/xml
    Date: Tue, 21 Apr 2015 19:03:29 GMT
    Location: h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml
    Server: Protected by COMODO WAF
    Elapsed Time: 304 ms.
    
    Attempting to test potential Autodiscover URL h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml
    Testing of the Autodiscover URL was successful.
    
    Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
    The Microsoft Connectivity Analyzer successfully retrieved Autodiscover settings by sending an Autodiscover POST.
    
    
    Did another test on Outlook 2010
    If i leave port 443 enabled on the client domain, it will complain of a ssl mismatch due to the redirection to cpanel server domain. When i disable port 443 on my firewall it skips the test and goes to URL get of auto discover.xml

    I also had to change my ciphers using https://wiki.mozilla.org/Security/Server_Side_TLS#Intermediate_compatibility_.28default.29
    on exim, or the client would reject our ciphers since it didn't have SSL3 with error

    (SSL_accept): error:1408A0C1:SSL routines:SSL3_GET_CLIENT_HELLO:no shared cipher
    TLS client disconnected cleanly (rejected our certificate?)

    after all this still not able to get iOS to auto detect.
     
    #3 JonTheWong, Apr 21, 2015
    Last edited by a moderator: Apr 21, 2015
  4. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    I re-tested with a domain that has SSL to confirm.

    Code:
    Attempting to test potential Autodiscover URL h ttps://domain.tld:443/Autodiscover/Autodiscover.xml
        Testing of the Autodiscover URL was successful.
    
    Attempting to resolve the host name domain.tld in DNS.
      The host name resolved successfully.
    
    Testing TCP port 443 on host domain.tld to ensure it's listening and open.
      The port was opened successfully.
    
    Testing the SSL certificate to make sure it's valid.
        The certificate passed all validation requirements.
    
    The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server domain.tld on port 443.
        The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.
    
    Validating the certificate name.
        The certificate name was validated successfully.
    
    Certificate trust is being validated.
        The certificate is trusted and all certificates are present in the chain.
    
    Testing the certificate date to confirm the certificate is valid.
        Date validation passed. The certificate hasn't expired.
    
    Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
        The Microsoft Connectivity Analyzer successfully retrieved Autodiscover settings by sending an Autodiscover POST.
    
    The only issue i can foresee is the certificate is SHA-2 and not SHA-1.. Based on the above i don't see an issue but its possible. Also the changes to cipher.

    Updated Dovecot with the new cipher.

    Re-tested with Mac Mail, setting up "Other Account" saw the discovery, but automatically moved to "this account needs to be setup manually"

    Apache logs show

    Code:
    [21/Apr/2015:17:43:19 -0400] "POST /autodiscover/autodiscover.xml HTTP/1.1" 200 1227
    [21/Apr/2015:17:43:19 -0400] "POST /cgi-sys/autodiscover.cgi HTTP/1.1" 200 1227
    
    Using Thunderbird i see this during discovery.
    Code:
    [21/Apr/2015:17:48:25 -0400] "GET /mail/config-v1.1.xml?emailaddress=testuser%40domain.tld HTTP/1.1" 200 910
    
    I also noticed this in apache error log

    Code:
    [Tue Apr 21 17:43:19.669524 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: [2015-04-21 17:43:19 -0400] warn [autoconfig] Could not create dir "//.cpanel" at /usr/local/cpanel/Cpanel/Config/LoadConfig.pm line 260: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669655 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Config::LoadConfig::loadConfig('/etc/remotedomains', HASH(0x2f07520), '') called at /usr/local/cpanel/Cpanel/Email/AutoConfig.pm line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669699 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Email::AutoConfig::eek:utlook() called at cgi-sys/autoconfig.cgi.pl line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669730 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \teval {...} called at cgi-sys/autoconfig.cgi.pl line 36: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669848 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: [2015-04-21 17:43:19 -0400] warn [autoconfig] Could not create dir "//.cpanel/caches" at /usr/local/cpanel/Cpanel/Config/LoadConfig.pm line 260: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669940 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Config::LoadConfig::loadConfig('/etc/remotedomains', HASH(0x2f07520), '') called at /usr/local/cpanel/Cpanel/Email/AutoConfig.pm line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.669997 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Email::AutoConfig::eek:utlook() called at cgi-sys/autoconfig.cgi.pl line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.670036 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \teval {...} called at cgi-sys/autoconfig.cgi.pl line 36: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.670127 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: [2015-04-21 17:43:19 -0400] warn [autoconfig] Could not create dir "//.cpanel/caches/config" at /usr/local/cpanel/Cpanel/Config/LoadConfig.pm line 260: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.670216 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Config::LoadConfig::loadConfig('/etc/remotedomains', HASH(0x2f07520), '') called at /usr/local/cpanel/Cpanel/Email/AutoConfig.pm line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.670270 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \tCpanel::Email::AutoConfig::eek:utlook() called at cgi-sys/autoconfig.cgi.pl line 37: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    [Tue Apr 21 17:43:19.670311 2015] [cgi:error] [pid 32544] [client 127.0.0.1:34549] AH01215: \teval {...} called at cgi-sys/autoconfig.cgi.pl line 36: /usr/local/cpanel/cgi-sys/autodiscover.cgi
    
    
     
    #4 JonTheWong, Apr 21, 2015
    Last edited by a moderator: Apr 21, 2015
  5. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not sure if this will help but i tested a wget do the auto discover url and i get this result

    Code:
    Location: h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml [following]
    
    --2015-04-21 18:31:39--  h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml
    Reusing existing connection to domainbasedonoutlooktweaksettings.tld:443.
    HTTP request sent, awaiting response... 302 Found
    Location: h ttps://domainbasedonoutlooktweaksettings.tld/autodiscover/autodiscover.xml [following]
    20 redirections exceeded.
    
     
    #5 JonTheWong, Apr 21, 2015
    Last edited by a moderator: Apr 21, 2015
  6. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for the edit, my bad on structure.
    After more testing, I can confirm auto discovery works on Outlook 2007.
     
    Infopro likes this.
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket for any issues that persist so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  8. JonTheWong

    JonTheWong Active Member

    Joined:
    Oct 8, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Montreal, Quebec
    cPanel Access Level:
    Root Administrator
    Twitter:
    cPanel tickets ID# 6410533

    The solution provided in 11.48.2 should resolve my issue with Outlook. Still would like auto configuration for iOS devices.

    I'll rely on cPanel Email configurations as a fix for now.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    To note, cPanel version 11.48.4.2 was released on April 21st, 2015 with the inclusion of this case:

    Fixed case 181725: Autodiscover: don't spew warnings to Apache's error log.

    Per our release notes, in cPanel & WHM version 11.48, we have added support for iOS devices (iPhone, iPad, and iPhone) to AutoConfig. You may see an unsigned certificate warning on your iOS device when you use this option. It is safe to accept the configuration file.

    Thank you.
     
Loading...

Share This Page