John Schmerold

Well-Known Member
Apr 21, 2004
81
6
158
st. louis
cPanel Access Level
Root Administrator
Auto discover insists on using %domain% for the imap & smtp server.

How do we get it to use mail.%domain% ?

I have read and fought with AutoConfig and Autodiscover - cPanel Knowledge Base - cPanel Documentation for hours, but I am no closer to solving this problem.

I suspect the magic is in this line "information about how to use a custom XML file", but I have no idea where to put the XML file. It seems like I should be able to edit a file somewhere on the system, but I cannot find it.

BTW, I found a script to help in the troubleshooting of this problem:
automx/automx-test at master · sys4/automx · GitHub

It sure beats putting test accounts in Outlook, Android, Thunderbird & iPhone, only to be told "you're a dummy this will never work"
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello,

You can browse to "WHM >> Tweak Settings" and enable the following option under the "Domains" tab:

"Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"

This will automatically create autodiscover and autoconfig proxy subdomains as well as the autodiscover SRV records needed for Outlook and Thunderbird email auto configuration for local domains.

Could you enable this option and let us know if the issue persists, or let us know if this option is already enabled?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Done - hours ago. That's what has been so frustrating, it seems that I have turned over every stone, twig and blade of grass.
But it still does not work!
Feel free to open a support ticket using the link in my signature so we can take a closer look at your system to see what's happening.

Thanks!