Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Autodiscovery SPF issue

Discussion in 'E-mail Discussion' started by rahnev, Feb 28, 2019.

  1. rahnev

    rahnev Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    54
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Bulgaria
    cPanel Access Level:
    Root Administrator
    Hello,

    I have following settings in Exim Configuration Manager, cPanel v78:

    Smarthost support - * mta.brand.tld
    Autodiscovery SPF include hosts from the smarthost route list - Off
    SPF include hosts for all domains on this system - node.brand.tld

    It actually added in zone file:
    ... include:node.brand.tld include:brand.tld...

    Why it adds include:brand.tld although Autodiscovery SPF is OFF.

    If I have no smarthost support enabled - it works as expected - adds only include:node.brand.tld

    Is this a bug?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,284
    Likes Received:
    2,154
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @rahnev,

    I've been unable to reproduce this behavior on a test system (the zone only populates a single include: entry in the TXT record). Can you open a support ticket so we can see what's happening on your system? You can post the ticket number here and I'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rahnev

    rahnev Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    54
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Bulgaria
    cPanel Access Level:
    Root Administrator
    @cPanelMichael

    yes, there is no problem. I managed to get what happened.

    When cPanel updated to v78 the following option was ON by default and actually it added include:brand.tld to zone files.
    Autodiscovery SPF include hosts from the smarthost route list

    However I didn't noticed it then. And after I added "SPF include hosts for all domains on this system - node.brand.tld" found both records in zone files.

    So everything is OK. Thanks.
     
    cPanelMichael likes this.
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,284
    Likes Received:
    2,154
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi @rahnev,

    Thanks for sharing the outcome. I've marked this thread as solved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice