The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AutoDiscovery XML Not Found

Discussion in 'E-mail Discussions' started by jjvideo25, Oct 27, 2016.

Tags:
  1. jjvideo25

    jjvideo25 Member

    Joined:
    Jan 13, 2013
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    I'm trying to configure cPanel email auto-discovery, but when I try and set up a test email account on Outlook, it does not work.

    The XML file that Outlook is looking for the configuration settings in is located at https:/cpanelemaildiscovery.cpanel.net/autodiscover/autodescover.xml

    However, that file does not exist on the server. I am getting "The requested URL /autodiscover/autodescover.xml was not found on this server."

    I'm guessing that is why AutoDiscover is not working. Can this be fixed on cPanel's side?

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you run the command below from your server and let us know the output?

    Code:
    curl -D /dev/stdout --data-binary '<EMailAddress>test1@domain.tld</EMailAddress>' -l https://domain.tld/autodiscover/autodiscover.xml
    Replace "test1@domain.tld" with the actual email account, and "https://domain.tld" with the actual domain name. Ensure to replace the domain names with examples in your response.

    Thank you.
     
  3. jjvideo25

    jjvideo25 Member

    Joined:
    Jan 13, 2013
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    HTTP/1.1 404 Not Found
    Date: Wed, 02 Nov 2016 14:47:41 GMT
    Server: Apache
    Content-Length: 346
    Content-Type: text/html; charset=iso-8859-1

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /autodiscover/autodiscover.xml was not found on this server.</p>
    <p>Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    </body></html>
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page