mhofer

Member
May 10, 2013
16
0
1
cPanel Access Level
Root Administrator
Hi there

I have just upgraded to cPanel 11.38 to test the new features, one thing is the new autodiscover-feature for email.

what i want to achieve is that our customer with domain example.com can enter [email protected] in his mail client and automatically receives the following configuration:
IMAP: servername.ourhost.com, SSL
SMTP: servername.ourhost.com, SSL

Now i have enabled the new features (AutoConfigure and AutoDiscover and _AutoDiscover set) in whm while changing the 'host to publish srv records' to servername.ourhost.com.

of course we have a wildcard certificate installed for ourhost.com.
the SRV records get created successfully, however when i test the autodiscover-feature in thunderbird with [email protected] a get the following settings:
IMAP: ourhost.com, SSL
SMTP: ourhost.com, SSL
Which is incorrect. I also changed the hostname in /var/cpanel/ssl/dovecot-CN and /var/cpanel/ssl/exim-CN with no effect.

also there is no host setup under servername.ourhost.com which could provide the required XML-Files for autodiscovery, don't know where it currently gets the information from oO
Changing the certificates-name is not possible either, it just uses the default entry in the certificate (ourhost.com).

I hope this was clear and someone can point me in the right direction?

Regards,
Marcel
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
23
143
Houston, TX
cPanel Access Level
Root Administrator
Now i have enabled the new features (AutoConfigure and AutoDiscover and _AutoDiscover set) in whm while changing the 'host to publish srv records' to servername.ourhost.com.
That setting changes the server mentioned in the SRV record, not the actual mail server value. In other words, it changes where the mail client is told to look for the settings, not the actual settings. By default, cpanelemaildiscovery.cpanel.net is the server in the SRV record, but if you have an SSL certificate installed on a virtual host, you can override that setting.
 

mhofer

Member
May 10, 2013
16
0
1
cPanel Access Level
Root Administrator
Hi Jared

Thanks for your reply. As you know I also opened a support ticket on this case which was now solved.

For anyone wondering: If you want to use the new autodiscover feature, you have to set up that xml file manually - the setting does nothing but creating the dns-entries.

I am currently working on a solution and will report back.

Greets