Automated update process fails (yum)

vtek

Registered
Jan 22, 2016
4
0
1
Finland
cPanel Access Level
Root Administrator
Hey,

I've been having cPanel update issues for the past two months now. yum fails to update some packages. As a workaround I have manually ran yum with --skip-broken function. But its getting annyoing. I've been trying to solve the issue but have not had success. Quite the contrary, I think I broke something more the other day while trying to fix this. As now I get notification about:

Code:
cPanel & WHM failed to update.

Sysup: Needed system RPMs were not installed: libtiff-devel
Manually trying to install that package with yum I get the following (which also is the original error):

Code:
[2016-01-28 03:19:44 +0200]  [2273] Error: Package: libtiff-4.0.3-18.el6.x86_64 (nvirt)
[2016-01-28 03:19:44 +0200]  [2273]  You could try using --skip-broken to work around the problem
[2016-01-28 03:19:44 +0200]  [2273]  You could try running: rpm -Va --nofiles --nodigest
[2016-01-28 03:19:44 +0200]  [2273] The system failed to execute yum with the arguments “-y -c /etc/yum.conf update” because of an error: The “/usr/bin/yum” command (process 2288) reported error number 1 when it ended. : Error: Package: libtiff-4.0.3-18.el6.x86_64 (nvirt)
[2016-01-28 03:19:44 +0200]  [2273]  Requires: libjbig.so.2.1()(64bit)
[2016-01-28 03:19:44 +0200]  [2273] Error: Package: 1:cups-libs-1.4.2-72.el6.x86_64 (@base)
[2016-01-28 03:19:44 +0200]  [2273]  Requires: libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
[2016-01-28 03:19:44 +0200]  [2273]  libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
[2016-01-28 03:19:44 +0200]  [2273]  Not found
[2016-01-28 03:19:44 +0200]  [2273] Error: Package: gdk-pixbuf2-2.24.1-6.el6_7.x86_64 (@updates)
[2016-01-28 03:19:44 +0200]  [2273]  Requires: libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
[2016-01-28 03:19:44 +0200]  [2273]  libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
[2016-01-28 03:19:44 +0200]  [2273]  Not found
[2016-01-28 03:19:44 +0200]  [2273] Error: Package: lcms-1.19-1.el6.x86_64 (@base)
[2016-01-28 03:19:44 +0200]  [2273]  Requires: libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
[2016-01-28 03:19:44 +0200]  [2273]  libtiff.so.3()(64bit)
[2016-01-28 03:19:44 +0200]  [2273]  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
[2016-01-28 03:19:44 +0200]  [2273]  Not found
[2016-01-28 03:19:44 +0200]  [2273] checkyum version 22.3
I have root access and my box info is:

Code:
/etc/redhat-release:CentOS release 6.7 (Final)
/usr/local/cpanel/version:11.52.2.5
/var/cpanel/envtype:kvm
CPANEL=release
Server version: Apache/2.4.16 (Unix)
Server built:  Sep 30 2015 14:59:31
Cpanel::Easy::Apache v3.32.1 rev9999
PHP 5.5.29 (cgi-fcgi) (built: Sep 30 2015 15:08:15)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
mysql  Ver 14.14 Distrib 5.5.47, for Linux (x86_64) using readline 5.1
Many thanks,

J
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Hello :)

This looks like an issue with your system packages. Please post the output from the following command:

Code:
rpm -qa|grep tiff
Also, do you notice any error messages when running the "yum reinstall libtiff" command?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Please let us know if installing the libtiff-devel package addresses the issue:

Code:
yum install libtiff-devel
Thank you.
 

vtek

Registered
Jan 22, 2016
4
0
1
Finland
cPanel Access Level
Root Administrator
Thanks again Michael for your reply.

I get the following errors while trying to install that package:

Code:
--> Running transaction check
---> Package libtiff-devel.x86_64 0:4.0.3-18.el6 will be installed
--> Processing Dependency: libtiff(x86-64) = 4.0.3-18.el6 for package: libtiff-devel-4.0.3-18.el6.x86_64
--> Processing Dependency: libtiffxx.so.5()(64bit) for package: libtiff-devel-4.0.3-18.el6.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: libtiff-devel-4.0.3-18.el6.x86_64
--> Running transaction check
---> Package libtiff.x86_64 0:3.9.4-10.el6_5 will be updated
--> Processing Dependency: libtiff.so.3()(64bit) for package: gdk-pixbuf2-2.24.1-6.el6_7.x86_64
--> Processing Dependency: libtiff.so.3()(64bit) for package: lcms-1.19-1.el6.x86_64
--> Processing Dependency: libtiff.so.3()(64bit) for package: 1:cups-libs-1.4.2-72.el6.x86_64
---> Package libtiff.x86_64 0:4.0.3-18.el6 will be an update
--> Processing Dependency: libjbig.so.2.1()(64bit) for package: libtiff-4.0.3-18.el6.x86_64
--> Finished Dependency Resolution
Error: Package: libtiff-4.0.3-18.el6.x86_64 (nvirt)
  Requires: libjbig.so.2.1()(64bit)
Error: Package: 1:cups-libs-1.4.2-72.el6.x86_64 (@base)
  Requires: libtiff.so.3()(64bit)
  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
  libtiff.so.3()(64bit)
  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
  Not found
Error: Package: gdk-pixbuf2-2.24.1-6.el6_7.x86_64 (@updates)
  Requires: libtiff.so.3()(64bit)
  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
  libtiff.so.3()(64bit)
  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
  Not found
Error: Package: lcms-1.19-1.el6.x86_64 (@base)
  Requires: libtiff.so.3()(64bit)
  Removing: libtiff-3.9.4-10.el6_5.x86_64 (@base)
  libtiff.so.3()(64bit)
  Updated By: libtiff-4.0.3-18.el6.x86_64 (nvirt)
  Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I probably should do some man on yum as I'm new to RPM's...
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Check the /etc/yum.repos.d directory and see if you are using any custom YUM repos:

Code:
ls -al /etc/yum.repos.d
You may need to disable any non-standard REPO files to allow YUM to proceed. Keep in mind this is a system administration issue that's unrelated to the cPanel software itself.

Thank you.
 

vtek

Registered
Jan 22, 2016
4
0
1
Finland
cPanel Access Level
Root Administrator
^^

Ah well, as it turns out there was a rogue repo added by my server provider for some reason. (nvirt). I did not realize it was a 3rd party repo so didnt pay much attention to it. Removed the repo and things work now as they should. I'll be smarter next time ;).
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.