Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Automatically changing exim configuration after restart

Discussion in 'E-mail Discussion' started by Ur4n1uM-235, Jan 2, 2019.

  1. Ur4n1uM-235

    Ur4n1uM-235 Registered

    Joined:
    Jan 2, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Hi!

    Everytime I restart the server (after some update that requires it), all sent mail get rejected.
    "550 XXX is not permitted to relay through this server without authentication"
    I need to change this particular option at exim configurations / mail:
    "EXPERIMENTAL: Rewrite From: header to match actual sender"
    It start as "Disabled", but then I need to change it to "Remote" or "All", and than change it back to "Disabled" so outgoing mail work again.
    I'm pretty tired of doing this manually and have no clue on how to change this setting via command line, so I can enable/disable automatically at boot.

    Can anyone help?
    Thank you, and a happy new year! :)
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @Ur4n1uM-235

    There shouldn't be a reason why this setting is requiring being changed like this.
    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Ur4n1uM-235

    Ur4n1uM-235 Registered

    Joined:
    Jan 2, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Hi!
    Sorry I took so long.
    11203427
    :)
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Ur4n1uM-235


    No worries! It looks like an analyst was already able to help you resolve the issue by making an addition to /etc/exim.localopts. Please let us know if the issue persists!

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Ur4n1uM-235

    Ur4n1uM-235 Registered

    Joined:
    Jan 2, 2019
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Actually he pointed me which file holds exim configurations and what to change.
    I created a script to do change this setting to "remote", update and restart exim, change this setting back to "disabled" update and restart exim again, and added it to my crontab at startup.
    This way my system forces exim to change this setting, and fixes the issue (which should not exist, as exim should see the setting as disabled and work properly, but that's not happening).
    :)
     
    cPanelLauren likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice