Autoresponder not working if body of reply message has reply header in it

ismadman

Member
Aug 7, 2012
5
0
1
cPanel Access Level
Website Owner
Hi there, Newbie here.
I have an issue using a mailing program and have been told to look here for an answer.

I have an autoresponder set up to reply to messages that aren't monitored from newsletters we send.

We are using acymailing but we have already eliminated any issues with that.

The problem is the Autoresponder works fine if I send an email directly to the address ( [email protected] )
It sends me back a message with the info I added in the autoresponder section of cPanel , Which is correct and working fine.

BUT, If i receive a newsletter from my mail program ( acymailing ) with the reply to address set to [email protected], THEN, I reply to that newsletter ( Email ) which sends it back to the autoresponder address ( [email protected] ) I do not receive the autoresponse.

The only way it will respond correctly is ,while replying, I need to remove the reply headers out of the body section of the reply email , then send . Then it will work .

An example of 2 messages.

If I send the 1st one as a reply it doesn't respond
if I remove the headers, then reply, it does.

Anyone have any idea on how to fix this as my clients have no idea to do this and they shouldn't need to.

Example 1 - Doesn't respond

From: < [email protected]>
Reply-To: < [email protected]>
Date: Mon, 6 Aug 2012 23:41:38 -0600
To: < [email protected]>
Subject: Contractor Insurance

Please see attached current Contractor Insurance Information at the end of this email ( Download Link ).
If you require any additional information please do not hesitate to contact our Marketing Team at: [email protected]
Best Regards

Example 2 - Once the header is removed, I receive the autoreponse

Please see attached current Contractor Insurance Information at the end of this email ( Download Link ).
If you require any additional information please do not hesitate to contact our Marketing Team at: [email protected]
Best Regards
 

Infopro

Well-Known Member
May 20, 2003
17,113
508
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Re: Autoresponder not working if body of reply message has reply header in

Is that "hint" on the Auto Responders page of any use?

Hint: If you do not create a forwarder or email account with the same address as each auto responder, mail sent to the auto responder will only be handled by the auto responder before it is discarded.
 

ismadman

Member
Aug 7, 2012
5
0
1
cPanel Access Level
Website Owner
Re: Autoresponder not working if body of reply message has reply header in

Is that "hint" on the Auto Responders page of any use?
Thanks for the quick reply.
I tried with an account set up and without and the result is exactly the same.
I still need to remove the reply header out of the body of the email to receive an auto response.
Any other thoughts ? I don't want or need their replies either. They can be discarded after the autoresponder has responded.

autoresp.jpg
 

ismadman

Member
Aug 7, 2012
5
0
1
cPanel Access Level
Website Owner
Re: Autoresponder not working if body of reply message has reply header in

I can give someone access to test . As I can't work this out .
Autoresponder responds when mail is sent directly to its address ( new mail addressed to [email protected] )
Autoresponder doesn't respond when someone receives an email and replies to that email ( With replyto set to [email protected] ). Only way it WILL work as a reply is to remove the reply headers from the BODY of the email then they receive the autoresponder message.
 

ismadman

Member
Aug 7, 2012
5
0
1
cPanel Access Level
Website Owner
Re: Autoresponder not working if body of reply message has reply header in

You might want to ask over at the joomla forums or at acymailing support.
Yeah I did all that before coming here. Acymailing checked everything. They said to try here.
I will test outside of joomla etc
 

ismadman

Member
Aug 7, 2012
5
0
1
cPanel Access Level
Website Owner
Re: Autoresponder not working if body of reply message has reply header in

Yes that was my thoughts . For this thread I will work it out with them again and post here. ThanksIP for all your insight. Great support :)