Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Autoresponder perl script error

Discussion in 'E-mail Discussion' started by Alferqm, Oct 15, 2018.

  1. Alferqm

    Alferqm Registered

    Joined:
    Oct 15, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Hi all.

    The autoresponders of two different accounts and two different domains are not working as they should. Sometimes they do, but 5 out of 6 times, the sender receives a Mailer-Daemon message instead of the autoresponder configured one.

    Here is an example, including .pm file and line of error at the bottom.
    Code:
    
    From: Mail Delivery System [mailto:Mailer-Daemon@xxxxxx.com]
    Sent: lunes, 15 de octubre de 2018 13:49
    For: sender@yyyyyyy.com
    Subject: Mail delivery failed: returning message to sender
    
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
    pipe to |/usr/local/cpanel/bin/autorespond autoresponderaccount@accountdomain.com
    /home/account/.autorespond
    generated by autoresponderaccount@accountdomain.com
    
    The following text was generated during the delivery attempt:
    
    ------ pipe to |/usr/local/cpanel/bin/autorespond autoresponderaccount@accountdomain.com
    /home/account/.autorespond
    generated by autoresponderaccount@accountdomain.com ------
    
    Argument contains empty host portion of address at
    /usr/local/cpanel/Cpanel/Email/Object.pm line 168.
    
    
    
    Any hint of why is this happening or how to solve it and make autoresponders work correctly would be appreciated.

    Thank you very much in advanced.
    Regards.
     
    #1 Alferqm, Oct 15, 2018
    Last edited by a moderator: Oct 15, 2018
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,206
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Alferqm

    I see a few tickets opened for this issue specifically but none of them were able to be resolved. I'd like for you to open a ticket so that we can look into the issue on this system specifically.

    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice