Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Autoresponder problem -- need some help

Discussion in 'General Discussion' started by sneader, Jul 18, 2005.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    When an outside user sends e-mail to an e-mail address that has an Auto Responder, they receive the Auto Response, BUT... they also receive this message:

    __________________________

    Delivery-date: Mon, 18 Jul 2005 01:55:44 -0500
    From: Mail Delivery System <Mailer-Daemon@www3.myhostname.com>
    To: some@outsideuser.com
    Subject: Mail delivery failed: returning message to sender
    Date: Mon, 18 Jul 2005 01:55:36 -0500


    This message was created automatically by mail delivery software.


    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:


    pipe to |/usr/local/cpanel/bin/autorespond test@customer.com /home/customer/.autorespond
    generated by test@customer.com


    The following text was generated during the delivery attempt:


    ------ pipe to |/usr/local/cpanel/bin/autorespond test@customer.com/home/customer/.autorespond
    generated by test@customer.com------


    2005-07-18 01:55:30 "timeout_dns" is no longer available in retry rules (it has never worked) - treated as "timeout"


    ------ This is a copy of the message, including all the headers. ------
    (snip)

    __________________________

    I know I've seen that "timeout_dns is no longer available in retry rules" in some config file somewhere recently, so maybe I goofed up that particular file, but I'm drawing a blank at the moment. Any help would be appreciated.

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I've opened up a ticket on this one, since I didn't get any feedback from anyone. I'm guessing this isn't a cPanel issue at all, but I'm stumped and figure I better at least run it by cPanel to make sure.

    I'll let you know the results, as always...

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dwykofka

    dwykofka Well-Known Member

    Joined:
    Aug 6, 2003
    Messages:
    394
    Likes Received:
    3
    Trophy Points:
    168
    it is a cpanel issue I have the same problem and it just started today after latest build update..

    -----Original Message-----
    From: Mail Delivery System [mailto:Mailer-Daemon@core1.serverdomain.com]
    Sent: Monday, July 18, 2005 6:11 PM
    To: gshields@userdomain.com
    Subject: Mail delivery failed: returning message to sender

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    tpinochet@userdomain.com
    local delivery failed
    pfann@userdomain.com
    local delivery failed
    cfann@userdomain.com
    local delivery failed
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Make sure that you haven't specified the timeout in your local exim configuration. You can check this through the WHM's exim conf editor, the file /etc/exim.conf.local, and in the files in /usr/local/cpanel/etc/exim/cf.

    After removing the option, run /scripts/buildeximconf to rebuild the exim.conf. This should get rid of the problem.
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,155
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Hi Ben. Here is how my cPanel tech explained it when he closed my ticket:

    Dear customer,
    The reason for this is the timeout_DNS line in your /etc/exim.conf that I have currently commented out.

    Further details about exim's behavior can be found here:
    http://www.mirrormonster.com/exim/ChangeLogs/ChangeLog-4.30

    35. The "timeout_DNS" error in retry rules, also documented since at least
    1.62, also never worked. As it isn't clear exactly what this means, and
    clearly it isn't a major issue, I have abolished the feature by treating it
    as "timeout", and writing a warning to the main and panic logs.

    I believe the fact that everything was generating these error messages was genreally the problem. Please let us know if you have any further problems.


    So, I guess it was my exim config. Thanks for being on top of this -- all seems fine now... except I didn't get any e-mail letting me know that anyone had responded to this thread :confused:

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice