The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Autoresponder's problems with Russian.

Discussion in 'E-mail Discussions' started by HEKTO, Dec 5, 2007.

  1. HEKTO

    HEKTO Member

    Joined:
    Dec 17, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hello!

    I have some issues with using Russian in autoresponders messages.

    First:

    I set up cp1251 codepage for autoresponder's messages and entered some text. But when a message had come to me I saw that 'From' and 'Subject' of the message were well but their were MIME-coded using koi-8r codepage. It is not the problem cause I can read it but it is strange because I chose another codepage.

    The problem is though the body of message was coded using cp1251 codepage and there was correct 'Content-type' header the body of the message was not shown correctly. I think it was because there was not MIME-Version header in the message. Because of that I need to change codepage in my email-client to windows-1251 everytime I want to read the autoresponder's messages.

    Second:

    Autoresponder allows to use several tags (such as %subject%) in the message. It takes subject (or name, or from) from the original message and substitute these tags by this information. But if these header fields are originally MIME encoded Autoresponder replace these tags by encoded information ( for example =?koi8-r?B?0NLP18XSy8E=?= ).

    I think Autoresponder should decode these original fields before replacing tags in the reply message.

    How can it all be fixed?
     
  2. HEKTO

    HEKTO Member

    Joined:
    Dec 17, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Can anyone help me?
     
Loading...

Share This Page