Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED AutoSSL and user valid SSL

Discussion in 'General Discussion' started by mahdy_sharifi, Dec 8, 2016.

Tags:
  1. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    I have 200 acount on any server , on this server any user have valid own SSL cert (www.domain.com) , but when other customer open there website with https , this user website open. (same www.domain.com) , I even Cpanel SSL for some user but again that user website open. (www.domain.com) is there any misconfig ?

    Thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    no , when i enable autossl for any user , this not work and then client use HTTPS:// his site forward to server primary SSL website .
    (in our server primary SSL installed on server hostname)
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To clarify, on the website where this happens, did AutoSSL install a certificate, or did AutoSSL fail to install a certificate? If it failed, the best course of action would be to address whatever is preventing the AutoSSL certificate installation.

    Thank you.
     
  5. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    185
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    I installed auto SSL CRT without error.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Are you sure there are no rewrite rules in the .htaccess file within the website's document root or it's script's configuration file that's redirecting it to the other domain name? If so, feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page