AutoSSL automatically enabled?

spiderlinginc

Member
Mar 15, 2010
21
0
51
To cPanel,

I am very unhappy that this autoSSL feature has been automatically enabled and essentially forced on me to use. I do not like Comodo!! To top it off, my server SSL was switched from the current SSL with another provider expiring at the beginning of Feb to cPanel / Comodo. Very unimpressed!! I have spent a significant amount of time cleaning this up instead of focusing on my business.

You want to encourage the use of SSL, fine. But do not automatically force the use of an SSL from a provider that you may be ok using, but others like myself are not.

You dropped the ball on this cPanel!!

BTW, autoSSL is and has been disabled as verified by the server provider techs.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,902
2,226
363
cPanel Access Level
DataCenter Provider
Twitter
Hello,

We offer the following option under the "Domains" tab in "WHM >> Tweak Settings":

Replace SSL certificates that do not match the local hostname

Per it's description:

When you enable this option, the checkallsslcerts script will replace any SSL certificates that do not match the hostname of the server with a cPanel-signed certificate. This includes wildcard certificates.

You can disable this option to ensure your existing service SSL certificates are not automatically replaced.

Thank you.
 

spiderlinginc

Member
Mar 15, 2010
21
0
51
I have disabled AutoSSL under Home »SSL/TLS »Manage AutoSSL in the Providers tab, unchecked "Allow AutoSSL to replace invalid or expiring non-AutoSSL certificates" under the Options tab and selected "Disable AutoSSL" under the Manage Users tab. The server SSL keeps changing back to the cPanel instead of the one I've paid for. I DO NOT want to use Comodo SSL and shouldn't be forced to.
 

24x7server

Well-Known Member
Apr 17, 2013
1,893
91
78
India
cPanel Access Level
Root Administrator
  • Like
Reactions: spiderlinginc

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,902
2,226
363
cPanel Access Level
DataCenter Provider
Twitter
I have disabled AutoSSL under Home »SSL/TLS »Manage AutoSSL in the Providers tab, unchecked "Allow AutoSSL to replace invalid or expiring non-AutoSSL certificates" under the Options tab and selected "Disable AutoSSL" under the Manage Users tab. The server SSL keeps changing back to the cPanel instead of the one I've paid for. I DO NOT want to use Comodo SSL and shouldn't be forced to.
Hello,

You didn't reference the option referenced in my previous post. It's the one you need to disable if you don't want the service certificates automatically replaced.

Thank you.
 
  • Like
Reactions: spiderlinginc

spiderlinginc

Member
Mar 15, 2010
21
0
51
Hello,

We offer the following option under the "Domains" tab in "WHM >> Tweak Settings":

Replace SSL certificates that do not match the local hostname
Hi,

You can disable the SSL generation from AutoSSL for the services on your server. Check the below link:
How to Disable the cPanel Store as an SSL Certificate Provider in WHM - cPanel Knowledge Base - cPanel Documentation

Also, in the tweak settings, you have to look for a setting that says "Replace SSL certificates that do not match the local hostname"
Tried the above setting changes as well and it is still replacing the existing host SSL. I am waiting to renew it until it is closer to the renewal date, but I shouldn't have to deal with this in the meantime.

Thank you.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,902
2,226
363
cPanel Access Level
DataCenter Provider
Twitter
Tried the above setting changes as well and it is still replacing the existing host SSL. I am waiting to renew it until it is closer to the renewal date, but I shouldn't have to deal with this in the meantime.
Could you open a support ticket using the link in my signature so we can take a closer look at this?

Thank you.