AutoSSL failed to request SSL certificate Permission Denied

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,295
313
Houston
Hi @rivali

Unfortunately, there's a bit more to this, in our ticket system we immediately get a banner/warning when certain items are present, one of those items is 90-day certificates. Your ticket has one of those banners based on the IP address in the ticket and the Company ID which the license is through. This indicates that the provider disabled this through their Manage2 interface.

While I understand they are indicating that they did not disable AutoSSL I am certain that 90-day certificates are disabled in that Manage2 interface. I do believe your hosting company may have done this accidentally but none the less this would not have anything to do with the updates that were pushed out, these are unrelated and wouldn't cause the banner we're seeing.

This is something they modified in their interface and we cannot change the setting. If they're not sure how to resolve this so that you can use AutoSSL we would be more than happy to assist them through a ticket of their own.

Thank you,
 

rivali

Member
Mar 4, 2014
15
0
51
cPanel Access Level
Root Administrator
Thanks for that information, cPanelLauren! I will tell them what you said and ask them to double-check. Maybe someone accidentally disabled something and didn't realize it.
 

rivali

Member
Mar 4, 2014
15
0
51
cPanel Access Level
Root Administrator
Hi cPanelLauren,

You were spot on! The hosting company opened a ticket with cPanel support and it was resolved very quickly. They had never heard of the setting before so it must have been an accidental error. I just ran a test renewal for one of the three domains and it went perfectly. I'm leaving the other two to be picked up by the nightly check, just to make sure that that is also working properly now. Thank you so much for all your help and for your patience with this long thread!
 

jessicarose

Registered
Aug 29, 2019
2
0
1
Phoenix AZ
cPanel Access Level
Root Administrator
For Everyone else - - - If you have a valid cPanel License, and you are getting this error:

ERROR AutoSSL failed to request an SSL certificate for “domain.com” because of an error: (XID 76dwkv) The cPanel Store returned an error (X::AuthenticationFailure) in response to the request “POST ssl/certificate/free”: Unauthorized

You should try this cPanel script:
usr/local/cpanel/cpkeyclt

If you do not have a valid cPanel license you should do the following:
  1. purchase a cPanel license.
  2. login your server via SSH.
  3. run usr/local/cpanel/cpkeyclt command and wait until its accomplishment.
Option #1 worked for me!!
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,295
313
Houston
For Everyone else - - - If you have a valid cPanel License, and you are getting this error:

ERROR AutoSSL failed to request an SSL certificate for “domain.com” because of an error: (XID 76dwkv) The cPanel Store returned an error (X::AuthenticationFailure) in response to the request “POST ssl/certificate/free”: Unauthorized

You should try this cPanel script:
usr/local/cpanel/cpkeyclt

If you do not have a valid cPanel license you should do the following:
  1. purchase a cPanel license.
  2. login your server via SSH.
  3. run usr/local/cpanel/cpkeyclt command and wait until its accomplishment.
Option #1 worked for me!!
Keep in mind that this is pending your license provider hasn't disabled this feature. In this thread @jessicarose we are primarily talking about an issue in which the license provider was a partner that had disabled the ability for people who had purchased a cPanel license through them to obtain SSL certificates. In a lot of cases this is done so that the provider can provide their own offerings.