Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

AutoSSL fails on wildcard subdomains

Discussion in 'General Discussion' started by jhawkins003, Jul 12, 2016.

Tags:
  1. jhawkins003

    jhawkins003 Member

    Joined:
    Jun 24, 2014
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Sounds fantastic! So in testing today, we have run across a couple of domains that have thrown the following error:

    The cPanel Store returned an error (X::Item::Validation) in response to the request “POST ssl/certificate/free”: Generic exception​

    Could this be a rate-limit of some sort? Happy to look into logs if directed where to look.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I've moved this post into it's own thread.

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jhawkins003

    jhawkins003 Member

    Joined:
    Jun 24, 2014
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Happy to, and thank you for your assistance in helping us track down the issue! Our support ticket (7598989) has now been created.
     
  4. jhawkins003

    jhawkins003 Member

    Joined:
    Jun 24, 2014
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    In follow-up conversations with one of my developers, I think we may have stumbled upon the issue. The two domains in question host test installs for WordPress multisite - which requires a wildcard subdomain entry in the cPanel DNS. Since this entry is associated with the respective accounts, AutoSSL is almost certainly attempting to assign a cert against it - which is probably failing.

    Also updating the ticket accordingly.
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Internal case CPANEL-7481 is now open to address an issue where if a user has a wildcard subdomain that resolves back to the server, then when AutoSSL runs for that user, an error like this is generated:

    Code:
    The cPanel Store returned an error (X::Item::Validation) in response to the request “POST ssl/certificate/free”: Generic exception
    I'll update this thread with more information as it becomes available.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    The resolution for this issue was published with cPanel version 58.0.8:

    Fixed case CPANEL-7481: Make vhost SSL checks ignore “*.” subdomains.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice