Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Autossl fails when domain uses GSuite

Discussion in 'Security' started by gmorchiop, Nov 21, 2017.

Tags:
  1. gmorchiop

    gmorchiop Registered

    Joined:
    Mar 18, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Dear all:

    I have some issues with some domains that has GSuite as their mail server. Obviously the Autossl mail subdomain check will not be successful due to the reason that mail.domain.com is pointing to ghs.googleservices.com . Is there any way to point AutoSSL to another subdomain for checking?

    Thanks in advance
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,167
    Likes Received:
    1,933
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. web-project

    web-project Well-Known Member

    Joined:
    Nov 23, 2007
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    you don't need to point mail.domain.com to ghs.googleservices.com it's optional, as google g suite is working great just by pointing the MX records only.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    cPanelMichael likes this.
  4. tapanhp

    tapanhp Registered

    Joined:
    Jun 14, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    77380
    cPanel Access Level:
    Website Owner
    I am having a similar problem. AutoSSL unable to auto renew the certificate for mail.domain.com only. I only pointed my MX records.
    I got the following notification.

    "
    The system queried for a temporary file at [removed], but the web server responded with the following error: 404 (Not Found). A DNS (Domain Name System) or web server misconfiguration may exist. The domain resolved to an IP address that does not exist on this server. "
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,167
    Likes Received:
    1,933
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @tapanhp,

    Can you use the "dig" command referenced on the AutoSSL Troubleshooting Steps resource to verify "mail.domain.tld" resolves to the IP address associated with the cPanel account?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice