SOLVED AutoSSL Failure due to .htaccess

jmartinmds

Member
Jul 22, 2016
12
3
3
Maryland
cPanel Access Level
DataCenter Provider
Hello,

I'm having an issue with getting autossl to run on a site. The error I'm getting in the logs is:

WARN Apache detected an error in the Rewrite config. <pre>httpd: Syntax error on line 252 of /home/*******/public_html/.htaccess.A1GP_0OUyeAgh01U25cxz9WTTRwynrsy: &lt;/Directory&gt; without matching &lt;Directory&gt; section </pre> Please try again. at /usr/local/cpanel/Cpanel/HttpUtils/Htaccess.pm line 407.

I've tried running it several times and no luck. There was another forum post that suggested commenting out lines in .htaccess that had to do with https but that didn't work. The permissions for .htaccess and the public_html folder are correct. The .htaccess file is rather long and complex (this is a big site) and I'd like to do as little muddling in there as possible. Currently the site does not force over to www, if that makes a difference.

I'm running this on 64.0 with the native AutoSSL - Let's Encrypt module.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello,

Can you enable the "Use a Global DCV Passthrough instead of .htaccess modification (requires EA4)" option under the "Domains" tab in "WHM >> Tweak Settings" and let us know if domain validation attempts continue to fail?

Thank you.
 
  • Like
Reactions: jmartinmds