The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AutoSSL for sub-domain stuck in pending

Discussion in 'Security' started by nickwuk, Jul 5, 2017.

Tags:
  1. nickwuk

    nickwuk Member

    Joined:
    Jul 18, 2009
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    53
    I have several sub-domains that have been stuck in the AutoSSL pending queue (in WHM) for a week, an example log entry says:
    Code:
    The website “subdomain.mydomain.uk”, owned by “mycpanelusername”, has a faulty SSL certificate (OPENSSL_VERIFY:0:18:DEPTH_ZERO_SELF_SIGNED_CERT). AutoSSL will attempt to replace this certificate. 
    The main domain SSL is fine, is there a configuration setting I need to change for sub-domains?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,086
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look to see why the AutoSSL validation process is failing?

    Thank you.
     
  3. staberas

    staberas Member

    Joined:
    Aug 11, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens
    cPanel Access Level:
    Root Administrator
    I have the same error, havent done any changes to the server, previous domains certifications worked fine. It would be great if one of this post would post an actual/possible solution rather than making us submit a ticket.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,086
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @staberas,

    There are multiple reasons AutoSSL validation can fail, and I'm not seeing a single solution to the reported error message. You could try running the following command to see if more details about the AutoSSL failure are presented:

    Code:
    /usr/local/cpanel/bin/autossl_check --user=$username
    Thank you.
     
  5. nickwuk

    nickwuk Member

    Joined:
    Jul 18, 2009
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    53
    I wasn't able to create a support ticket from within WHM, I wasn't able to login to the Cpanel portal. However my host fixed it by temporarily removing the .htaccess file; Apparently the following code was blocking the validation:

    Code:
    <FilesMatch "\.(htaccess|htpasswd|ini|log|sh|inc|bak|phtml|sql)$">
        Order Allow,Deny
        Deny from all
    </FilesMatch>
    
     
    cPanelMichael likes this.
Loading...

Share This Page