Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AutoSSL installation failing on cPanel created subdomains

Discussion in 'Security' started by RickKukiela, Jan 3, 2018.

Tags:
  1. RickKukiela

    RickKukiela Member

    Joined:
    Jan 17, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chicago
    cPanel Access Level:
    Root Administrator
    Daily we get error messages from the AutoSSL script complaining that its unable to verify various subdomains.

    For starters, webdisk.* for every single domain when it comes due for a cert update, fails. Obviously because the domain is password protected by default so the verify cannot work.

    The other offenders are the cpanel.*, webmail.*, and autodiscover.* subs.

    All I can do is go into each cpanel and manually disable the autossl for those domains when they come up.

    This is extremely tedious and honestly probably not even desired. I want webdisk to have SSL, the cpanel and webmail addresses should have SSL.

    Autodiscover I dont care much about either was we dont use it.

    What is going on with this?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,998
    Likes Received:
    339
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might like to know about this setting.

    WebHost Manager »Server Configuration »Tweak Settings, Domains tab:
     
  3. RickKukiela

    RickKukiela Member

    Joined:
    Jan 17, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chicago
    cPanel Access Level:
    Root Administrator
    I appreciate the reply, however this setting is already enabled on my server and the problem persists...
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,468
    Likes Received:
    21
    Trophy Points:
    148
    cPanel Access Level:
    DataCenter Provider
Loading...

Share This Page